Possible Bug With Dataset SQL Filter

CMS Version

3.1.4

Issue

When attempting to filter a dataset on a layout with a < symbol, the dataset shows the no data template. The moment I change the symbol to >, the filter works. I’m trying to filter the dataset only to show an event that is currently taking place in a room.

These are the filters I tried that failed:
“DATE(NOW()) = startdate AND DATE(NOW()) > startime AND DATE(NOW()) < endtime”
“DATE(NOW()) = DATE(startdate) AND TIME(NOW()) > TIME(starttime) AND TIME(NOW()) < TIME(endtime)”

Everything within the filter besides the DATE(NOW()) < endtime & TIME(NOW()) < TIME(endtime) works.
Here are the filters I tested with that work:
DATE(NOW()) = startdate
DATE(NOW()) = startdate AND DATE(NOW()) > starttime
DATE(NOW()) = startdate AND DATE(NOW()) > startime AND DATE(NOW()) > endtime

I can’t get the < endtime to work on the filter for whatever reason. I also tried <= to no avail. I would appreciate it if anyone could give me some insight into my issue and help me. Thank you in advance!

Here’s an example of the dataset I just made for this post.

HI markjime, welcome to the community!

I have a test layout that filters dataset rows based on the current date and the < symbol seems to be working for me. I appreciate I am using a different filter statement to you but I would expect to see the same issue if there was a bug with using <. Please note I am using CMS version 3.3.3, in case this explains the difference in the performance.

This is the row data I created to test this:

The filter statement I am using in my Dataset Ticker widget is:

NOW() > StartDate AND NOW() < EndDate

You can see in my statement that I am using < and > without an issue.

Many Thanks.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.