Player: continuous XMDS requests

Hi,

When launching the player (which fails to load the layout), I get this on the CMS:
89.115.236.194 - - [08/Oct/2019:14:31:06 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”
89.115.236.194 - - [08/Oct/2019:14:31:05 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”
89.115.236.194 - - [08/Oct/2019:14:31:05 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”
89.115.236.194 - - [08/Oct/2019:14:31:03 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”
89.115.236.194 - - [08/Oct/2019:14:31:06 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”
89.115.236.194 - - [08/Oct/2019:14:31:05 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”
89.115.236.194 - - [08/Oct/2019:14:31:04 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”
89.115.236.194 - - [08/Oct/2019:14:31:04 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”
89.115.236.194 - - [08/Oct/2019:14:31:07 +0100] “POST /bindopor/web/xmds.php?v=5 HTTP/1.1” 200 703937 “-” “-”

Just a snippet, there are HUNDREDS of requests within seconds. The display is set for 3 simultaneous downloads but clearly ignoring it.

All these requests returned “200” but eventually Apache reaches the limit of workers and returns “500”, as expected.

Any hints on what’s going on? Using the latest Linux player (1.8 R3) and a non-docker 2.1.0 CMS; this same player can load other layouts without issues…

Have the same issue here… using Ubuntu 18 with 1.8R3 client. Xibo CMS 2.1.
on the client i see a message that says [SOAP] Connection reset by peer
does not appear to be any helpful information on the apache web server

Did some digging around…

This is the expected behavior: “Xibo Player” downloads files split into chunks using SOAP and this results in these many requests. You’re getting the errors because Apache2 isn’t configured to widthstand these many requests (…).

But that’s not the way to do it. You need to setup mod_xsendfile (libapache2-mod-xsendfile) and enable “Apache” on the CMS under Administration->Settings->Network->File Download Mode.
Check Download speed limited on Windows client.
After you do, launch a client and the pesky SOAP file requests will be replaced by:
"GET /web/xmds.php?file=bf12b851ad287cfc06707164b15da49c13d38f31bc7e7fbc57ba00788a9e7282&displayId=8&type=M&itemId=87 HTTP/1.1" 200 284466438 "-" "-"
… and the layout media will load MUCH faster.

Back to Apache, you should still set “KeepAlive Off” and play with the mpm_prefork settings to suit your load.

Hope this helps.

The Xibo Community site uses cookies. What are cookies?