PHP maxsize upload 32M


#1

Hi everybody.
There is few day i have a problem.

I want increase size to upload.
I use Synology with php5.6

I try lot of solution i read
I edit php.in (etc/php/php.in) in SSH
Change value of 3 lines ( 32 to 256m)

Save it ( :x!)
And restart all system.
Nothing work, limit still the same :frowning:

I don’t have .user.ini in my folder.

What can i do??


#2

[PHP]
engine = On
short_open_tag = On
asp_tags = Off
precision = 14
output_buffering = 4096
zlib.output_compression = Off
implicit_flush = Off
serialize_precision = 17
disable_functions =
disable_classes =
zend.enable_gc = On
expose_php = Off
max_execution_time = 240
max_input_time = 60
memory_limit = 128M
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED
display_startup_errors = Off
log_errors = On
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
html_errors = Off
variables_order = "GPCS"
request_order = "GP"
register_argc_argv = Off
auto_globals_jit = On
post_max_size = 256M
default_mimetype = "text/html"
default_charset = "UTF-8"
include_path = "."
extension_dir = "/usr/lib/php/modules"
sys_temp_dir = "/var/services/tmp"
enable_dl = Off
file_uploads = On
upload_tmp_dir = "/var/services/tmp"
upload_max_filesize = 256M
max_file_uploads = 20
allow_url_fopen = On
allow_url_include = Off
default_socket_timeout = 60

extension = bcmath.so
extension = bz2.so
extension = curl.so
extension = iconv.so
extension = ldap.so
extension = mcrypt.so
extension = openssl.so
extension = pdo_sqlite.so
extension = posix.so
extension = phar.so
extension = shmop.so
extension = sockets.so
extension = sqlite3.so
extension = zip.so

extension = syno_compiler.so

[CLI Server]
cli_server.color = On

[Date]
date.timezone = “Asia/Taipei”

[Phar]
phar.readonly = Off

[mail function]
sendmail_path = /usr/bin/ssmtp -t
mail.add_x_header = On

[SQL]
sql.safe_mode = Off

[bcmath]
bcmath.scale = 0

[Session]
session.save_handler = files
session.save_path = "/var/services/tmp"
session.use_cookies = 1
session.use_only_cookies = 0
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.cookie_httponly =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor = 1000
session.gc_maxlifetime = 1440
1,1 Top


#3

You might want to ask in Synology forums, as it’s not really a Xibo related question, I personally do not know if synology is handling php.ini in a different way.

Although it seems rather similar - https://forum.synology.com/enu/viewtopic.php?t=114636
I assume there is some sort of control panel as well, so you probably can use that to restart web server.

If you’d need to adjust more values please have a look here How do I upload files bigger than 2MB / How can I increase the upload file size limit?


#4

Finaly find it after one year hahaha:
$


In WEBSTATION / PHP/ Advance setting/ coeur (traduction?)

Find “Post max size” and change value , 1024 for me, don’t forget “M” like “1024M”