Old images showed up after upgrade how can I remove them?

Hello All

We had old Version of XIbo 1.6 something.

We had images and media files as well display layout which ware removed.
Yesterday I have upgraded Xibo to Version 1.7.4 this is where my problem starts.

When I go to Layout and Media I have old images showing here as well as New.
In Media I can only see new media I have uploaded.

I have run tidy up library in settings and I have also run Tidy up Library from Library Media.

Tidy Library
Tidying your Library will delete any media that is not currently in use.
There is 0 of data stored in 0 files . Are you sure you want to proceed?

How can I remove reference to Old pictures and media.

Thank you in advance.

The 1.7.4 upgrade won’t have brought back old data. I expect you retired the old layouts/images in the 1.6 system and now have the filter set in 1.7 to show those.

Start by deleting the old layouts. You can see them by setting Retired in the filter.

Then once the layouts are deleted, you can re-run the tidy or delete the media items individually from the Library (again setting the filter to show retired media items).

The fact it shows 0 data in 0 files however is concerning. It looks like you have no media files in the database in that case already!

Hello Alex

I had 1 Layout retired, I have unsigned files from it and when I did tidy up library it did find 2 files of 7.5 MB and it removed it.
When I go back to Library / Media and once I use Filter to show retired media it shows old media files however those files are not in library in /var/www/xibodata/.
When I want to delete file from Library / Media I can retire and remove from all layouts and retire. I can not delete it.

They are almost certainly retired media items, which are now being incorrectly shown. Can you edit this line:

https://github.com/xibosignage/xibo-cms/blob/develop/lib/pages/content.class.php#L391

To read:

$mediaList = $user->MediaList(NULL, array('type' => $mediatype, 'name' => $name, 'retired' => 0));

if that does the trick we will convert this over to a bug and get it fixed in the next release

Hello Alex and Dan

I just solved my problem.

  1. Layouts > Filter > Retired ( Yes ) >Only Unused.
    2.I have removed media from old Layouts
  2. Went back to Library >Media ans I have looked at the Retired Media and I have removed from there, However some would not delete.
    I have done fsck -a and rebooted system. Once system booted up I was able to remove rest of the old media.

Possible corruption of HDD was ans issue as well. Issue is solved

Thank you guys to pointing me to right direction