Nothing happens when I run php xmr.phar

I’m running XIbo CMS on CentOS 7 (x64). When I run php xmr.php, nothing happens… the terminal just returns me to a new prompt.

ZeroMQ is installed:
[root@server /home/xibo-cms/]# rpm -qa | grep zeromq zeromq-3.2.2-13.2.x86_64 zeromq-devel-3.2.2-13.2.x86_64

Here’s my config.json:
{ "listenOn": "tcp://", "pubOn": ["tcp://x.x.x.x:5556","tcp://"], "debug": false }

  1. ps -ax | grep xmr doesn’t reveal any running processes
  2. netstat -a | grep 5556 doesn’t show any open ports

What could be possibly going wrong?


I just went through this process.

Your instructions above did not say you added the php bindings for zeromq. I found the guide here:

I used the pear / pecl route with success.

With the json config file you have, I had an error when starting xmr. I was trying different things but I found an example of another config file that allowed xmr to start.

I’m still learning this new version so I can’t say if this config file is right or wrong. But it did allow xmr to start.

“listenOn”: “tcp://lo:50001”,
“pubOn”: [“tcp://”, “tcp://lo:50002”],
“debug”: false

Then you will need to create a custom systemd script to make a service out of the evocation command so the service starts on each system reboot.


Is there any reply on this? I cant seem to make the service up either.