No German language with IE


#1

Xibo server 1.7.2
With internet explorer no German language is possible in the CMS. With Google Chrome it works fine.
I’ve temporarily renamed the German language file in en_GB.mo and Internet Explorer shows German language in the CMS.


#2

You need to configure Internet Explorer to prefer German over English and the UI will switch automatically.

Alternatively, in the CMS settings, you can turn off auto detection and set a fixed language for the CMS.


#3

IE 11
Both suggestions do not work.

Google Chrome:
After turn off auto detection and set a fixed language (DE) for the CMS, Google Chrome switch to English Language.


#4

Both work when I try them here


#5

With IE you can switch to German ?


#6

If I set this:

I get this on my CMS:


#8

I’ve set your CMS to German.

The language code is de not DE. The reason it didn’t detect is you have browser detection turned off in the options.

I also noticed your library path is invalid. It must be a fully qualified path (eg /path/to/library not just library) otherwise you will have problems down the line.


#9

Thanks for your patience, it works now.

OK de is the correct setting and works now.

library path \xibo-library\test17x\ in this form works since version 1.4 and higher without problems. I’ve always done it that way.

Thank you again


#10

By all means continue using that at your risk. That value should be fully qualified so don’t be surprised if it stops working, or for example if you’re entire library were deleted because it wasn’t in the format we require.


#11

Hallo together,

What is the correct Format for the Language in german in the Settings->regional:

I have Version 1.8.12 of xibo

de_GB ??

About a correct auswer thanks


#12

As above, the correct value is de but by default it will use whatever language preference your browser tells us to use. The default language is only used if you turn detection off, or your browser doesn’t specify.