Newest Xibo Player

Is it possible to use the newest Xibo player with an older server? In particular I’m looking to use it with server 1.7.8 until I’ve completed its upgrade to 1.8.x

I believe it should work, however we generally recommend to use players and CMS in the same series, similarly after you upgrade the CMS, existing 1.7 players will still work, so you can then upgrade them over the time.