Mysql error update 1.6.3 to 1.7.6

Hi all,

I am getting this error when I attempting to upgrade from 1.6.3 to 1.7.6.

I’m on RHEL 6.5 (Santiago)

An error occurred populating the database. Statement number: 57. Error Message = [SQLSTATE[HY000]: General error: 1005 Can’t create table ‘xibo163.#sql-ac2_ae’ (errno: 121)]. File = [Array]. SQL = [ALTER TABLEblacklistADD CONSTRAINTblacklist_ibfk_1FOREIGN KEY (MediaID) REFERENCESmedia(mediaID), ADD CONSTRAINTblacklist_ibfk_2FOREIGN KEY (DisplayID) REFERENCESdisplay(displayid)].

I searched the forum posts, but I have not found the answer to my problem :o(
Any suggestions?

Thank you,
Alexandre

hmm, am I right to assume database called xibo163 is your current database?

Did you follow upgrading instructions? http://xibo.org.uk/manual/en/release_notes_1.7.6.html

Especially the part about cloning your database and granting permissions