Move 32:9 layout to the top in a 16:9 device


we want to use Xibo in an android box with 3840x2160 resolution.

The contents will be displayed in a 32:9 screen (3840x1080), so we have created a resolution of that size and created layouts with that resolution.

Xibo renders the 32:9 layout vertically centered in the 16:9 resolution (black in the top and the bottom).

This 32:9 screen, to be able to render a 16:9 image, needs to have it in the upper half. How can we make the layout not to display vertically centered, but at 0,0?

We tried creating a new display profile. We need to supply “0,0,3840,1080” as its size, which displays it vertically centered, otherwise we get weird results. I thought that setting that would paint the layout at 0,0 instead of vertically centered.

Thank you,

Thank you for your message. Setting your Display Profile to 0,0,3840,1080 should indeed set the Layout to appear starting from the top left corner of the screen, as shown in the box to the right in your diagram.

Can you confirm:

  • What version of the Xibo for Android Player you are using?
  • After you created the new Profile, did you set it for your Android Player to use in the Edit Display page, wait for the Player to connect to your CMS and collect those changes, restart the Player to action those received changes?

Many Thanks.


We’re using Android 2-201 and Xibo 2.0.2.

Yes, we are setting the profiles as you say.

Here you can see an image describing what we tried. We used two layouts, one at 3840x1080 and another at 3840x2160, with the contents at the top half and black at the bottom half. You can see the results when using the default profile, a custom profile with 0,0,3840,1080 and a custom profile with 0,0,3840,2160.

You can see the black as seen in the TV and what is displayed semi-transparent is what is not actually seen.

Thank you!

OK! We solved it.

We are somehow having trouble with the resolution in the Android system and it sets to 1920x1080 automatically when it should be using 3840x2160.

Then, to be able to display the 32:9 image in the top portion of the 16:9 screen we need to use a display profile with 0,0,1920,540.

Thank you!

My apologies that I have not replied sooner regarding this issue. I have been testing with my Android device and a 4K display but was unable to replicate your issue. Now I think I understand why.

First just want to say that I’m really glad you have resolved the issue, second I’m grateful that you returned to this post and confirmed what the solution was. It is quite possible that other users will encounter an issue like this in the future, hopefully this will be a helpful suggestion for them.

Many Thanks.

FWIW: I have an X96 android STB that’s happy to do 4k… but does so by upscaling to the TV res from it’s 720p frame buffer. An issue like this (device lying about the raster size to somebody) might be related to what you’re seeing, if not exactly that issue.