Migration fails during upgrade from 2.3.12 to 3.0.x

CMS Version

2.3.12 upgrading to 3.0.x

Installation Method


Operating System

Ubuntu 20.04.3 LTS



We just upgraded our Android licenses to v3 but can’t upgrade the CMS to use them.

A migration fails when upgrading our database from 2.3.12 to 3.0.x:

docker-compose logs -f shows:

cms-web_1         |  == 20200604103141 CommandImprovementsMigration: migrating
cms-web_1         |  == 20200604103141 CommandImprovementsMigration: migrated 0.2141s
cms-web_1         | 
cms-web_1         |  == 20200612141755 OauthUpgradeMigration: migrating
cms-web_1         | 
cms-web_1         | In PdoAdapter.php line 134:
cms-web_1         |                                                                                
cms-web_1         |   SQLSTATE[42S02]: Base table or view not found: 1051 Unknown table 'cms.oaut  
cms-web_1         |   h_access_tokens'                                                             
cms-web_1         |                                                                                
cms-web_1         | 
cms-web_1         | migrate [-c|--configuration CONFIGURATION] [-p|--parser PARSER] [-e|--environment ENVIRONMENT] [-t|--target TARGET] [-d|--date DATE] [-x|--dry-run]
cms-web_1         | 
cms-web_1         | Importing ca-certs

We’ve tried upgrading to 3.0.0, .1, .2, and .3 with the same error.

Here’s our upgrade procedure:

cd /opt/xibo
docker-compose down
cd /opt
mv xibo xibo-old
wget https://github.com/xibosignage/xibo-docker/archive/refs/tags/3.0.3.tar.gz
tar -xvf 3.0.3.tar.gz
mv xibo-docker-3.0.3 xibo
cp xibo-old/config.env xibo/
cp -r xibo-old/shared xibo/
cd xibo
docker-compose up -d

We have not modified docker-compose.yml which is why we’re not migrating it.

Previous upgrades within 2.x have worked well. Are we missing anything regarding the 3.x upgrade?

We are using the recommended Docker setup. The only “odd” thing I can think of in our setup is that we used to host the database remotely on MariaDB. We imported it into Xibo’s MySQL 5.7 a few versions ago using the shared/backup/import.sql procedure and it’s been working fine.

Here’s the full output of docker-compose logs -f: Attaching to xibo_cms-web_1, xibo_cms-db_1, xibo_cms-memcached_1, xibo_cms-quick - Pastebin.com

We’re happy to upload the database to Xibo staff if that’d help troubleshoot.

Xibo support helped me solve this by creating the missing table:

CREATE TABLE `oauth_access_tokens` (
`access_token` varchar(254) NOT NULL,
`session_id` int(11) NOT NULL,
`expire_time` int(11) NOT NULL,
PRIMARY KEY (`access_token`),
KEY `session_id` (`session_id`),
CONSTRAINT `oauth_access_tokens_ibfk_1` FOREIGN KEY (`session_id`) REFERENCES `oauth_sessions` (`id`) ON DELETE CASCADE

I added this early in the import.sql so that the table was created during the import.

Thank you Xibo support!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.