Issue with Windows Player not pushing content

Hello Community, our IT team hosted a 3.2.1 docker version CMS on a Ubuntu 18.04 (LTS) x64 sever
using a windows player v3-R305.1-win32-x86. The detail of our windows device is
CPU- Intel Apollo lake processor
Memory- 4GB
Storage- 64GB
The issue we are facing is all the 6 players connected to the CMS are only displaying the splash page but not pushing contents from the CMS. i tried to look the log page and out of the points listed the one issue i see repeatedly is " [Error swapping to HTTPS. E = Unable to connect to the remote serve" on the player side & a WEB error saying “Method not allowed. Must be one of: GET”.


Based on the previous suggestions on the community i have

  1. Disabled the “force HTTPS” in both the CMS & display setting.
  2. Check & confirmed both the CMS & player time
  3. Only pushed 2 simple layouts (a layout with 2 pictures & another one with only text on the layout editor) aside from the default layout.
  4. Turned off the Firewall & Network protection on the player devices since our CMS server is http://159

Can anyone please help us fix the problem to run our 6 displays?
Thank you

Hi Mak1,
Did you try to run XIBO Client setup to configure your Xibo player ? If Yes, did you see that your windows player is connected in the log comment ?
Did you try to connect to the console directly via an internet navigator from the player ?
Tell me.
Fred

Hey Fred thanks for the quick replay. for your first question i downloaded the player from the official site which comes with only the setup file (.exe) & did all the steps as per the details. that’s why it launched & worked properly for the first time. the problem stated occurring after i restarted the device & tried to use it again. regarding the connection i only tried WIFI but i believe i have a good connection since it worked properly for all the previous testes i did on the xibo cloud trial & localhost running on XAMPP.

Hey, by setup I meant Xibo Options … directly on the xibo player, you need first to kill the client and then the watchdog process

Next you have to check that the name of the player is unique in the advanced tabs

Tell me.

update on the problem am having. based on the display log, certain type of files are not being downloaded but i cant figure out why



Help from anyone is very welcomed???

If it helps, the cms modules status



Hey Mak1,

From your error messages it seems that the Player is trying to connect through Https while your cms is hosted under http://. I would suggest:

  1. Please disable firewall in the server and check if the files are getting downloaded
  2. Check the “Force https” settings under Display >> profile Settings>> “Force Https” is enabled for individual devices.

Regards,
Mukul

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.