Impossible to manually install Xibo 1.8.2

Hi everyone,

I tried to install Xibo on Raspbian by running those commands :

Sudo apt-get update
Sudo apt-get upgrade
Sudo apt-get install apache2 mysql-server php5 php5-curl php5-gd php5-mysql php5-mcrypt
Sudo wget https://github.com/xibosignage/xibo-cms/releases/download/1.8.2/xibo-cms-1.8.2.tar.gz -O xibo-server.tar.gz
Sudo tar -zxvf xibo-server.tar.gz
Sudo mv xibo-cms-1.8.2/ /var/www/html/xibo-server
Sudo chown www-data:www-data -R /var/www/html/xibo-server
Sudo mkdir /media/xibo-library
Sudo chown www-data:www-data -R /media/xibo-library

Then i tried to follow the link to connect to the app: http://localhost/xibo-server/web/index.php

Here on the second page (database creation), it was impossible to create a new Xibo database with informations below :

Host: localhost
Admin username : xibo_admin
Password : xxxxxxx
Database name : xibo
Database username : xibo_admin
Dataebase password : xxxxxxx

This is the error message i get after entering informations listed just before:

“Could not connect to MySQL with the administrator details. Please check and try again. Error Message = [SQLSTATE[HY000] [2005] Unknown MySQL server host ‘loacalhost’ (2)]”

Can anyone give me a little help please ?

You should not have “web” in the URL you use to access the CMS.

Please read the install guide, and adjust your Apache web root as required:

http://xibo.org.uk/manual-tempel/en/install_environment.html
http://xibo.org.uk/manual-tempel/en/manual_install.html

The Admin username for your MySQL instance is very unlikely to be xibo_admin. The admin username and password are the MySQL server credentials you set up for the administrative user when you installed it - typically “root” and whatever password you choose.

If i don’t use “web” in my URL, I don’t have access to the installation.

I tried to install CMS with this manual but i don’t succeed to configure ZeroMQ.

It looks alot to me like "web" in that URL. If you correctly configure the websever, that URL should be just http://localhost

The ZeroMQ requirement is tricky. That’s why we strongly recommend a Docker based install as we have done all that for you - although that does mean you won’t be able to run it on your RPi.

Failing that, you can run without XMR/ZeroMQ, but you will loose the Player actions functionality.

qbulard is correct. You have to go to http://localhost/xibo-server/web/ to access the installation on the latest versions when you install manually.

Unfortunately that only means that you’ve not configured your web server correctly - the entire Xibo folder (the place where you extracted the CMS files) must NOT be web servable.

To illustrate the point, I expect you can go to http://localhost/xibo-server/library/ which you absolutely do not want to be able to do.

The web server absolutely must be configured to serve files only from web and also configured to allow url_rewriting - this is covered in as much detail as we can, here: http://xibo.org.uk/manual-tempel/en/install_environment.html