Importing Layouts Containing DataSets

Is there anything more about importing layouts with datasets? We still seem to be unable to import datasets with our layouts.

We tried to import the layout, but found we could not import the dataset, as we can’t export it from 1.7.X. We tired to rebuild the dataset but ran into to trouble even trying to create that, as we can’t add data to the dataset without errors on that process too. We then also found that within the imported layout in 1.8.1 Docker, if you go to the region, and try to edit the timeline the cms throws errors and will not let you edit the timeline. You have to delete the region, add a new one, reconfigure it and then link the dataset, that we cannot add data to.

So basically in 1.8.1 datasets are completely broken for us.

Exporting datasets with the Layout was only introduced in 1.8, so you are correct that you cannot (unfortunately) export your DataSet’s in 1.7.

You are also correct - a Layout export containing a DataSet that we don’t know anything about will result in a dead Widget, because it refers to a DataSet that does not exist.

What do you mean by this?

You can’t import 1.7 layouts with Datasets into 1.8, however you could take a copy of your 1.7 installation, upgrade it to 1.8 and then export the Layouts from there. The export will contain the DataSet and import into your target CMS.

Alternatively you could open your 1.7 Layout Exports and add a file called dataset.json which contains a JSON array of DataSet names and codes. You can then put in the relevant DataSet code in your 1.8 install and tick “use existing”. The resulting Widget will be linked up.

Problems was actually a dataset we messed up when we tried to create a column with the same column names. It has been recorded as a bug.

Thank you for the feed back Dan. With that and the bug logged this can be closed.

1 Like