ForecastIO stuck on save

When i try to add a Forecast element to the timeline the module is stucked on save moment.
The gear continue to rotate and nothing happen…
If i click on get meteo there is no problem and i see all the data.
What do you thing it can be?

What CMS version do you please?

Did you try to clear browser cache / try different browser? Is it the same problem?

Version 1.7.9
I tried on Google Chrome and Microsoft Edge
I tried to clear cache but is the same.

In this case, you might want to navigate to Report Fault page and go through Report Fault wizard.
(enable debugging, recreate the issue, check logs).

You might want to also look at your server logs.

Here it is…

1506	17-01-23 09:22:35	CMS	User	DisplayList	SQL: SELECT display.displayid, display.display, displaygroup.description, layout.layout, display.loggedin, IFNULL(display.lastaccessed, 0) AS lastaccessed, display.inc_schedule, display.licensed, display.email_alert, displaygroup.DisplayGroupID, display.ClientAddress, display.MediaInventoryStatus, display.MacAddress, display.client_type, display.client_version, display.client_code, display.screenShotRequested, display.storageAvailableSpace, display.storageTotalSpace, currentLayout.layout AS currentLayout, currentLayout.layoutId AS currentLayoutId FROM display INNER JOIN lkdisplaydg ON lkdisplaydg.DisplayID = display.DisplayID INNER JOIN displaygroup ON displaygroup.DisplayGroupID = lkdisplaydg.DisplayGroupID LEFT OUTER JOIN layout ON layout.layoutid = display.defaultlayoutid LEFT OUTER JOIN layout currentLayout ON currentLayout.layoutId = display.currentLayoutId WHERE displaygroup.IsDisplaySpecific = 1 ORDER BY display. Params: array (
).

1505	17-01-23 09:22:32	CMS	Forecast\Forecast	request	Calling API with: https://api.darksky.net/forecast/[APIKEY]/51.504,-0.104?units=auto&lang=en&exclude=flags%2Cminutely%2Chourly

1504	17-01-23 09:22:32	CMS	forecastio	getForecastData	Getting Forecast from the API

1503	17-01-23 09:22:32	CMS	Cache	has	638b857e8919c7cde8bd549b2e5536ea Expired: 1485179658

1502	17-01-23 09:22:32	CMS	module		Module created with MediaID: LayoutID: 5 and RegionID: 47ff29524ce1b

1501	17-01-23 09:22:32	CMS	module		Creating new module with MediaID: LayoutID: 5 and RegionID: 47ff29524ce1b

1500	17-01-23 09:22:21	CMS	ForecastIo	loadTemplates	4

1499	17-01-23 09:22:21	CMS	module		Module created with MediaID: LayoutID: 5 and RegionID: 47ff29524ce1b

1498	17-01-23 09:22:21	CMS	module		Creating new module with MediaID: LayoutID: 5 and RegionID: 47ff29524ce1b

1497	17-01-23 09:22:19	CMS	module	SetMediaInformation	Existing Assigned Media XML is: \n <?xml version="1.0"?>
<root><media id="522caef6e13cb6c9fe5fac15dde59ef7" type="text" duration="15" lkid="" userId="1" schemaVersion="1" render="native">
<options><xmds>1</xmds><direction>none</direction><scrollSpeed>2</scrollSpeed><fitText>0</fitText></options>
<raw><text><![CDATA[<p style="text-align: center;"><span style="font-size:168px;"><strong><span style="font-family:arial,helvetica,sans-serif;"><span style="color:#FFFFFF;">Welcome to Xibo</span></span></strong></span></p>

<p style="text-align: center;"><span style="font-size:80px;"><span style="font-family:arial,helvetica,sans-serif;"><span style="color:#FFFFFF;">Open Source Digital Signage</span></span></span></p>

<p style="text-align: center;"><span style="font-size:48px;"><span style="color:#D3D3D3;"><span style="font-family:arial,helvetica,sans-serif;">This is the default layout - please feel free to change it whenever you like.</span></span></span></p>
]]></text></raw>
</media></root>

1496	17-01-23 09:22:19	CMS	Layout	GetLayoutXml	OUT

1495	17-01-23 09:22:19	CMS	Layout	GetLayoutXml	IN

Right, it will be something server side (php issue), the CMS logs in this case might not help much, you’d need to look at your web server logs.

In the webserver logs i don’t have any error…
It’s like button is firing nothing

What if i insert ut manually in the database?
Can i insert only the xml? Someone can give me an example of this xml