FLIP Clock as Timer - Client Issue


#1

Hi Xibo Team!

Good day,

I have an issue with the FLIP CLOCK used as timer, in the CMS & Layout preview, the timer I made for a specific date is working, but when pushed and viewed to my client displays it’s just displaying “00:00:00:00”

I already checked my set timezones in both the client and CMS, all are in sync and same timezone, but still the issue persists.

I already tried restarting the client and the client machine, but still the issue persists.
There are also no overlapping regions
I also tried “VERIFYING” all module, but still no luck.

CMS Version: 1.8.2
Client Version: 1.8.18

Please see attached screenshot for visual reference.


#2

Please also see my CLOCK settings

Countdown is from August 5, 2018. (Please see screenshot)


#3

I’d try setting the offset to

2018-08-07 12:00:00

I’m not aware of a specific bug, but 1.8.2 is now 8 minor versions out of date, so you might consider upgrading to 1.8.10 too.


#4

Alright, we’ll try to upgrade and see what happens.

No luck, for the changing of offset. I already tried later dates like August 20, but still no luck.

I also tried to check the FLIPCLOCK file (.htm) under the Xibo library in the client machine, and its running perfectly. I don’t know why the clock is not working, when viewed in the Xibo Client.

Maybe this issues is still worth checking for your team,

Thank you Alex as always,


#5

Hi @jcmacalindol
I’m no expert and it sounds to me like you know more about this than I.
But I was able to get a countdown working by setting the duration to however many seconds I needed it to count down. Hopefully this is what you were looking to do.


#6

Hi Ryan!

Good day,

I haven’t thought of doing that, let me try it next time!
But I think we have different requirements, did you try setting the OFFSET with the same pattern as mine?.
Thanks for this though, I will definitely try your solution next time!

Have a great day Sir! :slight_smile:


#7

I did try using the offset with the same pattern as you did, but I couldn’t tell it was changing anything.
The clock always started with whatever I set the duration as.
My original requirements can be found here. https://community.xibo.org.uk/t/countdown-timer/7585
I’m hoping one day the Clock widget will have a timer option and allow you to set a future date and time and will automatically calculate the time that needs to be displayed on the timer.


#8

Hi
Hi Guys,

I dont know, but it seems to be a new bug/issue in the new 1.8.12. release ?

The Flipclock in the preview works fine, everthing is ok, but on the Client it shows only 00:00:00:00.

Xibo-Client Version is 1.8.12-133 on windows 10

My offset is 2019-03-01 12:00:00

Have anybody the same issue?

Sunny Greetings from snowy Germany

Torsten


#9

I have been trying to replicate the issue you described but without success. Can you send me an exported copy of your Layout in a private message so I can try your Layout on my setup?

Many Thanks.


#10

Thank you for bringing this to our attention. I have created a Bug report for this issue, the Development team will resolve the issue as soon as possible. I have included a link to the report for reference:

My apologies for any inconvenience while this issue is resolved.

Many Thanks.


#11

Hi Guys,

I dont know, but it seems to be a new bug/issue in the new 2.0.0. release ?

The Flipclock dosen’t work in preview. It shows only 00:00:00:00.

Xibo-CMS is 2.0.0. Player is on Windows 2 R200-200

My offset is 2019-03-30 12:00:00

Have anybody the same issue?

Sunny Greetings from snowy Germany

Torsten


#12

Thank you for your message. I have created a Flip Clock with the below settings in CMS version 2.0.1 and found that it is showing the countdown without issue.

image
image
image

I have also set the Clock Face to 12h Clock and 24h Clock without an offset and was able to see the time in Preview layout. I would recommend upgrading your CMS to 2.0.1 to see if this resolves the issue. If it does not, please post the settings for your Widget as well as a screenshot of the zeroes you are seeing.

Many Thanks.


#13

HI Daniel,

Ok, i think i must explain the issus better:

Server: Xampp on Win 10. Xibo 1.8.12

I create a layout with one region, an put the clock widget in it.
Settings: Flipclock , Daycounter, Offset: 2019-04-19 12:00:00

Now in the previewmode everthing work fine (same as on your System), but not on my Display:

Display: Intel Stick PC with Win10 an Xibo Player Windows 2 R200-200

On the display it shows only 00:00:00:00

I setup a Testserver with 2.0.1 and report here again…

Greetings Torsten


#14

Hi,
i install a testserver with xampp on win10 and xibo 2.0.1

Then i create a layout with a flipclock like the same settings as above.

00:00:00 in Previemode, in the Preview and on the Display.

Work worse than befor in Xibo 1.8.12.

If you want i can send you the layout to do some testings?

Greetings from Germany
Torsten


#15

Thank you for the message and further information. You are correct that the V2-200 Player is also affected. A fix is currently in development and will be included in a future release of Xibo. Once again I appreciate the information you provided.

Regarding the preview shown in your image from the last message, the Offset is set to 2019-04-04 16:00. Can you change that to 2019-04-19 12:00:00 to see if the Preview then shows the correct Countdown? I ask because I still can’t replicate that in my 2.0.1 CMS:

Many Thanks.


#16

Hi Daniel

your wish is my order:

Greetings

Torsten