First Install - Failed with Code: 2


#1

I’m struggling here. I’m following the install guide and I seem to be stuck and not able to complete the install.

What I have tried…

  • Installed Windows 10 Pro from scratch. Joined to my domain.
  • Signed in as local admin
  • Installed Docker for Windows directly from their website. – This does end up failing to auto-start. Right-clicking the icon on the taskbar and choosing Restart does get it going.
  • Downloaded Xibo installer package to C:\Xibo\Install_Files\xibo-docker-2.0.1
  • Made a copy of the config.env.template and renamed to config.env. I didn’t make any changes because I didn’t see anything that really needed to be changed for a basic install.
  • PowerShell > cd C:\Xibo\Install_Files\xibo-docker-2.0.1
  • Ran docker-compose up -d and I receive the following error ERROR: Windows named pipe error: The system cannot find the file specified. (code: 2)

I’m not sure what else to do at this point. I’m following through the instructions, but I feel like something is missing. If someone could help, that would be awesome.

Thanks.


#2

I think there must be something not right with the Docker install as that’s where the error comes from.

Docker should auto-start, and so if it isn’t then perhaps there’s something from your domain policy interfering and preventing it from working properly.

On the Xibo install specifically, you can’t just copy config.env.template to config.env. You must at the very least set a MySQL password in that file - and I strongly suggest using the link in the notes in that file to generate something suitable.


#3

I definitely feels it’s related to Docker. This is the error info from Docker during the failed autostart.

Unable to start: The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: 'MobyLinuxVM' failed to start.

Failed to start the virtual machine 'MobyLinuxVM' because one of the Hyper-V components is not running.

'MobyLinuxVM' failed to start. (Virtual machine ID 2F9D96CC-BB80-4942-95BA-07D6CC517247)

The Virtual Machine Management Service failed to start the virtual machine 'MobyLinuxVM' because one of the Hyper-V components is not running (Virtual machine ID 2F9D96CC-BB80-4942-95BA-07D6CC517247).
at Start-MobyLinuxVM, <No file>: line 296
at <ScriptBlock>, <No file>: line 412
   at Docker.Core.Pipe.NamedPipeClient.Send(String action, Object[] parameters) in C:\workspaces\stable-18.09.x\src\github.com\docker\pinata\win\src\Docker.Core\pipe\NamedPipeClient.cs:line 36
   at Docker.Actions.DoStart(SynchronizationContext syncCtx, Boolean showWelcomeWindow, Boolean executeAfterStartCleanup) in C:\workspaces\stable-18.09.x\src\github.com\docker\pinata\win\src\Docker.Windows\Actions.cs:line 92
   at Docker.Actions.<>c__DisplayClass19_0.<Start>b__0() in C:\workspaces\stable-18.09.x\src\github.com\docker\pinata\win\src\Docker.Windows\Actions.cs:line 74
   at Docker.WPF.TaskQueue.<>c__DisplayClass19_0.<.ctor>b__1() in C:\workspaces\stable-18.09.x\src\github.com\docker\pinata\win\src\Docker.WPF\TaskQueue.cs:line 59

Since the domain OU may be an issue, I moved the computer to a less restrictive OU. I’ve also researched the web with some of the keywords from the Docker error info and can’t seem to get a good fix in place.

As for the SQL password, I added one.

For getting Docker to start, I can still do the right-click taskbar icon and choose Restart and it does.

I attempted to run docker-compose up -d again and it still kicks back
ERROR: Windows named pipe error: The system cannot find the file specified. (code: 2)

I decided to run docker-machine ls to see what VMs exist and none show up. I’m not sure if that’s related. Maybe nothing is supposed to show up until I can successfully run docker-compose up -d.

Any other ideas about this Docker issue?


#4

I may have determined the problem… nested VMs. My machine was a VM running on vSphere. I did a test on my local machine and it got up and running without issue. I guess I will need to figure out a local device that I can use for the same purpose, even though I prefer VMs.


#5

If you want to run inside a VM, then you are best running a Linux VM, as then there’s no double virtualisation required.


#6

For me, the solution was to just find another desktop machine that I could leave unattended. I installed Win 10 Pro x64 on it and got it going.

Doing a VM running Win 10 Pro on vSphere does not work without special configurations and it was a bit more than I had time for.

Thanks for your response, though, Alex.


#7

Ok… I spoke too soon. Earlier I was able to install everything on my local machine and got it working. Now, after installing it on a different machine, I try to go to http://localhost and it does not get to the login page.

I’m trying to dig around the support page and the web, but I can’t figure out why it’s not allowing me to get to that page.


#8

The stupidest thing… Since IIS was installed on this machine at some point before, the inetpub folder was on the C: drive. I deleted that and it instantly worked.