Fetch remote datasets doesnt work after upgrade to 3.0.0

After update to xibo 3.0.0 fetching the existing remote datasets doesnt work anymore. A new created remote dataset also will be fetched. The request of testdata while creating the remote dataset has worked.

Could you confirm that the dataset is being used in a scheduled Layout to be shown on a Player? If this is not the case it will stop syncing.

Thank you

yes these datasets are used in a scheduled layout

a little correction of my first post:
“A new created remote dataset also doesnt be fetched”

Thank you for confirming.

Could you try re-publishing your Layout and run the Fetch Remote Dataset task and see if it runs successfully? If it is successful, check the Dataset entry to see if the last sync date has updated. Restart the Player to see if the data then updates?

I tried all of these steps before posting the message here. The error message that the data set could not be synchronized appears in the message center even after manually calling the “Fetch Remote Dataset” task.

In that case could you put the CMS in debug mode and once the task has run, take a look at the log page and see if any errors/issues are shown.

I have attached the log. As I understand it, the data is fetched and parsed. After that, an error occurs before the table is filled with the data.

xibo_log_dataset.pdf (327.5 KB)

Thank you, from my understanding it looks like the data is fetched and parsed, but it then doesn’t validate properly - ie the data isn’t of the correct type for the column type in the dataset. I will ask a member of our dev team to confirm if that is the case and will provide any updates here.

I have spoken with the dev team who have identified that lat is set as a String which breaks the process as it should be a Number dataType, and have suggested the following amendments:

 'id' (string)
 'name' (string)
 'brand' (string)
 'street' (string)
 'place' (string)
 'lat' =  (number)
 'lng' = (number)
 'dist' = (number)
 'price' = (number)
 'isOpen' =  (html)  / change source to be string instead of bool then (string)
 'houseNumber' =  (string)
 'postCode' = (number)

If you do still experience issues with this after the suggested changes then please do come back to us.

1 Like

Now it works again, thank you very much for the solution. I had already changed the data types for testing purposes, but I never had the idea of using html as the data type for the Boolean value.

Thats great to hear, thanks for letting us know :+1:

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.