Failed to create remote DataSets

Hi there, i need help.

This is my json:

{
“zone”: “SGR01”,
“start”: “01-04-2019”,
“end”: “30-04-2019”,
“locations”: [
“Gombak”,
“Hulu Selangor”,
“Rawang”,
“Hulu Langat”,
“Sepang”,
“Petaling”,
“Shah Alam”
],
“prayer_times”: [
{
“date”: “01-04-2019”,
“datestamp”: 1554048000,
“imsak”: “5:47 am”,
“subuh”: “5:57 am”,
“syuruk”: “7:12 am”,
“zohor”: “1:20 pm”,
“asar”: “4:22 pm”,
“maghrib”: “7:24 pm”,
“isyak”: “8:33 pm”
},
{
“date”: “02-04-2019”,
“datestamp”: 1554134400,
“imsak”: “5:47 am”,
“subuh”: “5:57 am”,
“syuruk”: “7:11 am”,
“zohor”: “1:20 pm”,
“asar”: “4:22 pm”,
“maghrib”: “7:23 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “03-04-2019”,
“datestamp”: 1554220800,
“imsak”: “5:46 am”,
“subuh”: “5:56 am”,
“syuruk”: “7:11 am”,
“zohor”: “1:19 pm”,
“asar”: “4:23 pm”,
“maghrib”: “7:23 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “04-04-2019”,
“datestamp”: 1554307200,
“imsak”: “5:46 am”,
“subuh”: “5:56 am”,
“syuruk”: “7:11 am”,
“zohor”: “1:19 pm”,
“asar”: “4:23 pm”,
“maghrib”: “7:23 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “05-04-2019”,
“datestamp”: 1554393600,
“imsak”: “5:46 am”,
“subuh”: “5:56 am”,
“syuruk”: “7:10 am”,
“zohor”: “1:19 pm”,
“asar”: “4:24 pm”,
“maghrib”: “7:23 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “06-04-2019”,
“datestamp”: 1554480000,
“imsak”: “5:45 am”,
“subuh”: “5:55 am”,
“syuruk”: “7:10 am”,
“zohor”: “1:19 pm”,
“asar”: “4:24 pm”,
“maghrib”: “7:23 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “07-04-2019”,
“datestamp”: 1554566400,
“imsak”: “5:45 am”,
“subuh”: “5:55 am”,
“syuruk”: “7:09 am”,
“zohor”: “1:18 pm”,
“asar”: “4:24 pm”,
“maghrib”: “7:22 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “08-04-2019”,
“datestamp”: 1554652800,
“imsak”: “5:44 am”,
“subuh”: “5:54 am”,
“syuruk”: “7:09 am”,
“zohor”: “1:18 pm”,
“asar”: “4:25 pm”,
“maghrib”: “7:22 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “09-04-2019”,
“datestamp”: 1554739200,
“imsak”: “5:44 am”,
“subuh”: “5:54 am”,
“syuruk”: “7:09 am”,
“zohor”: “1:18 pm”,
“asar”: “4:25 pm”,
“maghrib”: “7:22 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “10-04-2019”,
“datestamp”: 1554825600,
“imsak”: “5:43 am”,
“subuh”: “5:53 am”,
“syuruk”: “7:08 am”,
“zohor”: “1:17 pm”,
“asar”: “4:25 pm”,
“maghrib”: “7:22 pm”,
“isyak”: “8:32 pm”
},
{
“date”: “11-04-2019”,
“datestamp”: 1554912000,
“imsak”: “5:43 am”,
“subuh”: “5:53 am”,
“syuruk”: “7:08 am”,
“zohor”: “1:17 pm”,
“asar”: “4:26 pm”,
“maghrib”: “7:22 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “12-04-2019”,
“datestamp”: 1554998400,
“imsak”: “5:42 am”,
“subuh”: “5:52 am”,
“syuruk”: “7:08 am”,
“zohor”: “1:17 pm”,
“asar”: “4:26 pm”,
“maghrib”: “7:22 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “13-04-2019”,
“datestamp”: 1555084800,
“imsak”: “5:42 am”,
“subuh”: “5:52 am”,
“syuruk”: “7:07 am”,
“zohor”: “1:17 pm”,
“asar”: “4:26 pm”,
“maghrib”: “7:21 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “14-04-2019”,
“datestamp”: 1555171200,
“imsak”: “5:42 am”,
“subuh”: “5:52 am”,
“syuruk”: “7:07 am”,
“zohor”: “1:16 pm”,
“asar”: “4:27 pm”,
“maghrib”: “7:21 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “15-04-2019”,
“datestamp”: 1555257600,
“imsak”: “5:41 am”,
“subuh”: “5:51 am”,
“syuruk”: “7:07 am”,
“zohor”: “1:16 pm”,
“asar”: “4:27 pm”,
“maghrib”: “7:21 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “16-04-2019”,
“datestamp”: 1555344000,
“imsak”: “5:41 am”,
“subuh”: “5:51 am”,
“syuruk”: “7:06 am”,
“zohor”: “1:16 pm”,
“asar”: “4:27 pm”,
“maghrib”: “7:21 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “17-04-2019”,
“datestamp”: 1555430400,
“imsak”: “5:40 am”,
“subuh”: “5:50 am”,
“syuruk”: “7:06 am”,
“zohor”: “1:16 pm”,
“asar”: “4:27 pm”,
“maghrib”: “7:21 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “18-04-2019”,
“datestamp”: 1555516800,
“imsak”: “5:40 am”,
“subuh”: “5:50 am”,
“syuruk”: “7:06 am”,
“zohor”: “1:15 pm”,
“asar”: “4:28 pm”,
“maghrib”: “7:21 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “19-04-2019”,
“datestamp”: 1555603200,
“imsak”: “5:39 am”,
“subuh”: “5:49 am”,
“syuruk”: “7:05 am”,
“zohor”: “1:15 pm”,
“asar”: “4:28 pm”,
“maghrib”: “7:21 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “20-04-2019”,
“datestamp”: 1555689600,
“imsak”: “5:39 am”,
“subuh”: “5:49 am”,
“syuruk”: “7:05 am”,
“zohor”: “1:15 pm”,
“asar”: “4:28 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “21-04-2019”,
“datestamp”: 1555776000,
“imsak”: “5:39 am”,
“subuh”: “5:49 am”,
“syuruk”: “7:05 am”,
“zohor”: “1:15 pm”,
“asar”: “4:28 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “22-04-2019”,
“datestamp”: 1555862400,
“imsak”: “5:38 am”,
“subuh”: “5:48 am”,
“syuruk”: “7:05 am”,
“zohor”: “1:15 pm”,
“asar”: “4:29 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “23-04-2019”,
“datestamp”: 1555948800,
“imsak”: “5:38 am”,
“subuh”: “5:48 am”,
“syuruk”: “7:04 am”,
“zohor”: “1:14 pm”,
“asar”: “4:29 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “24-04-2019”,
“datestamp”: 1556035200,
“imsak”: “5:38 am”,
“subuh”: “5:48 am”,
“syuruk”: “7:04 am”,
“zohor”: “1:14 pm”,
“asar”: “4:29 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “25-04-2019”,
“datestamp”: 1556121600,
“imsak”: “5:37 am”,
“subuh”: “5:47 am”,
“syuruk”: “7:04 am”,
“zohor”: “1:14 pm”,
“asar”: “4:29 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “26-04-2019”,
“datestamp”: 1556208000,
“imsak”: “5:37 am”,
“subuh”: “5:47 am”,
“syuruk”: “7:04 am”,
“zohor”: “1:14 pm”,
“asar”: “4:30 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “27-04-2019”,
“datestamp”: 1556294400,
“imsak”: “5:36 am”,
“subuh”: “5:46 am”,
“syuruk”: “7:03 am”,
“zohor”: “1:14 pm”,
“asar”: “4:30 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “28-04-2019”,
“datestamp”: 1556380800,
“imsak”: “5:36 am”,
“subuh”: “5:46 am”,
“syuruk”: “7:03 am”,
“zohor”: “1:14 pm”,
“asar”: “4:30 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “29-04-2019”,
“datestamp”: 1556467200,
“imsak”: “5:36 am”,
“subuh”: “5:46 am”,
“syuruk”: “7:03 am”,
“zohor”: “1:13 pm”,
“asar”: “4:30 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
},
{
“date”: “30-04-2019”,
“datestamp”: 1556553600,
“imsak”: “5:35 am”,
“subuh”: “5:45 am”,
“syuruk”: “7:03 am”,
“zohor”: “1:13 pm”,
“asar”: “4:31 pm”,
“maghrib”: “7:20 pm”,
“isyak”: “8:31 pm”
}
]
}

I have set 9 column based on ‘prayer_times’ Data root. But when i ‘run now’ in task, nothing happen. Data from remote json not inserted to my dataset.

Anyone can help me? Thanks in advance!

This is my column setting for order no 3 (imsak)

i believe the setting is correct but nothing happen when i ‘run now’ in Task.

Could you show me a screenshot of the Task page in your CMS please?

When you do the run now, all it means that the task should be executed, it does not actually execute the task ie first we need to confirm that the fetch remote dataset task actually did run - screenshot should clarify that.

If you could also tell me the CMS version you’re using please?

It’s Version 1.8.12

here you go the screenshot of the Task page;

The tasks didn’t run at all in your CMS.

I therefore assume that it is not docker installation?
If that’s the case, then please have a look here - https://xibo.org.uk/docs/setup/xtr-routine-tasks

That will need to correctly configured and running for the tasks to work.

OK, thanks for the prompt reply.