Error message any operation

xibo administration side don’t work and produce error… You don’t have permission to access /xibo/web/displayprofile/2 on this server.

Could you please tell us a bit more about your server environment and Xibo version that you have installed?

Is it new installation or upgrade?
Was it working for some time and now suddenly stopped?

is a new installation, never work. version is 1.8.0
i saved the trobleshoot.zip file, how can i do uploading this file?

I assume that’s custom installation ie without docker?

It will probably have something to do with filesystem permissions on your server.

You can upload the log archive to dropbox/googleDrive and share the download link with me via private message - if you intend to share it here publicly, please make sure that there are no sensitive information there.

this is the file.

https://www.dropbox.com/s/l9t64f64a4i4kqc/troubleshoot.zip?dl=0

good morning to all, unfortunately I have to tell you that the installation of on-line web server does not work and you do not understand what causes errors on permissions.

Not sure what you mean by “the installation of the on-line web server does not work”. There are thousands of installs using Xibo. Once things are configured correctly on the web server, installation is quick and very easy. As for, “you do not understand what causes errors on permissions”, I think Peter did suggest you check your file system permissions, as that is where the permissions problem is. Xibo cannot set file permissions for you. That must be done on the administrator level before Xibo can even install.

I would suggest looking at the installation guide as there are a number of problems with your installation.

The web folder should not be publicly accessible. You have permissions problems, most likely your web server (Apache,Nginx, or whatnot) does not have the correct permissions. Looking at your log files, I see that large file uploads does not appear to be enabled, and also ZMQ is either not installed, or not configured correctly. There may be some other issues as well.

ok, thank’s

I expressed myself badly, I do not know how the permissions and do not understand the strange behavior, for example must be set can create a display profile without errors but I can not delete it, why?

Can you tell me which server type you are using? Apache, Nginx, IIS?

Did you go through the installation guide while installing?

is apache, yes, I followed the installation guide, I can load the phpinfo file if needed …

Ok Apache, is this on a Windows, or Linux operating system?

Just to make thing easier, I would recommend renaming the existing xibo folder to something like xibo_old and placing a new copy of the xibo 1.8.1 in to a new folder called xibo. Then please make sure that Apache has full access to this folder. If on Linux, this should help. If on Windows, you really shouldn’t need to do anything if you are running Apache via WAMP.

What happens currently if you open a browser and go to http://{YOUR_SERVER_IP}/xibo, or http://{YOUR_SERVER_IP}/xibo/web/?

Once you get an error free response from the browser on one of those then you need to make the web folder inaccessible from the internet. I can give you more instructions, but knowing the operating system first will help.

I know this seems like a giant step backwards from where you are right now, but I think getting everything correct from the install point is needed.


Something else that just hit me about your first post is:
xibo/web/displayprofile/2

Are you only getting the permissions problem when you log back in after being logged out? If so that is a bug that I believe has been fixed in 1.8.0, (I know it pertained to layouts, not sure about displays)

is on linux, i have error when confirm the modify. i can send you the credential for administrator in privat if you want .

I would love to help you more on this, but I have a lot going on at the moment, and I think you would need to start fresh. You might reach out to say Spring Signage and see if this is something they might do for you. But I think they will probably suggest you get a hosted solution with someone like them.

thanks for your time, if and when it will solve my problem I will talk here.

You should not have web in the URL you use to access Xibo.

If you do, as in your screenshot, then the CMS hasn’t been correctly installed. Your webserver’s web root should be that web directory - the files above it need to be there, but should not be web serveable.

If you’re running on a Linux server, then a Docker install is both supported by the project, and should be straight forward.

thanks, I’ll try to work on permits although frankly I did not understand what I should do.