Error installing xibo on hosting

I’m trying to install xibo on a shared hosting, but I’m getting the following error when I access the directory where I place the xibo files

… / install / install / install / install / install / install / install / install / …

Generates a loop in this install.

My installation will be in a sub directory, I tried to change the .htaccess

follows as it is now:

RewriteEngine On

#RewriteBase / xibo / web /

fix authorization header

RewriteCond% {HTTP: Authorization}. +
RewriteRule. * - [E = HTTP_AUTHORIZATION:% {HTTP: Authorization}]

requests for api authorize

RewriteCond% {REQUEST_FILENAME}! -F
RewriteCond% {REQUEST_URI} ^ / api / authorize /.*$
RewriteRule ^ api / authorize / index.php [QSA, L]

requests that start with api go down to api / index.php

RewriteCond% {REQUEST_FILENAME}! -F
RewriteCond% {REQUEST_URI} ^ / api /.*$
RewriteRule ^ api / index.php [QSA, L]

install

RewriteCond% {REQUEST_FILENAME}! -F
RewriteCond% {REQUEST_URI} ^ / install /.*$
RewriteRule ^ /web/install/index.php [QSA, L]

maintenance

RewriteCond% {REQUEST_FILENAME}! -F
RewriteCond% {REQUEST_URI} ^ / maint /.*$
RewriteRule ^ maint / index.php [QSA, L]

all others - i.e. web

RewriteCond% {REQUEST_FILENAME}! -F
RewriteCond% {REQUEST_FILENAME}! -D
RewriteCond% {REQUEST_FILENAME}! . (Css | js | png | jpg) $
RewriteCond% {REQUEST_URI}! ^ / Dist /.$
RewriteCond% {REQUEST_URI}! ^ / Theme /.
$
RewriteRule ^ index.php [QSA, L]

I deleted the .htcass file from the directory / xibo / web /

and executed the path manually in xibo / web / install / index.php so the loop didn’t happen anymore, but an error on the installation page was presented as shown in the image below:

I have experienced the same thing, in my case i had to temporarily disable the SSL/HTTPS redirection.

I will try to disable https redirection. boces had a problem with htaccess too?

You must not have web in the URL you’re using to access the CMS. What you’re doing there is wrong.

Please check the install guide, and better still, use the method we suggest for install (with Docker). We don’t offer support for custom installs here as there’s just too many variables for us to help people in a reasonable amount of time.

@alex I unzipped the xibo into a subfolder in my hosting, when I try to access just http://bomdemaissupermercados.com.br/plugy the page doesn’t even open.

I have in that same hosting a version before 1.8.12 in this version it works perfectly inside a subfolder.

It isn’t supposed to work as you describe.

Only the web folder should be exposed to the Internet. Please read the installation guide which explains your options, however, shared hosting very often doesn’t allow the changes you need and so in general we say it isn’t suitable for use with Xibo.

The CMS is alot more intensive than it used to be, and you need to be able to run PHP applications from the command line not just from the webserver

The Xibo Community site uses cookies. What are cookies?