Docker Toolbox not creating /shared subfolder

I’m still struggling with a docker toolbox install of 1.8.0 on windows 10 home. I’ve extracted the xibo-docker folder (originally to c:\ but same result when changed to c:\users, as suggested in another topic), changed/saved config.env, and ran docker-compose up -d. The CMS works as expected, but all changes are lost if I reboot the machine - I’m assuming due to the lack of the /shared subfolder being created in the xibo-docker folder. Is there a step I’m missing? Thanks.

Yes your changes are lost because that folder isn’t created.

As far as I’m aware, with Docker Toolbox, any path within C:\Users will work.

Did you down the containers when you moved them?

If not, run docker-compose down, then put the CMS files somewhere under C:\Users, and then with the files in the correct place, run docker-compose up -d

Does the shared directory get created now?

Still no shared folder:


That all looks sensible.

I’d suggest running docker-compose down

Then uninstall Docker Toolbox, reboot, then try installing again.

No luck. Even after uninstalling, rebooting, and reinstalling everything (w/ xibo-docker under c:\users), still no /shared subfolder. Looking @ kitematic (below), you can also see that there are no local folders for xibodocker_cms-web_1. Any other suggestions?

You could try changing it in Kinematic, although I’ve not tried that personally.

I tried that - was not successful.

If both mechanisms can’t map those, then it does suggest there’s a problem with the Toolbox install.

When you uninstalled, did you delete the VirtualBox VM that it uses as well? If not, you could try downing your containers, deleting that VM, and then running the Docker Toolbox Quickstart Terminal again which should re-provision it I think

In addition to uninstalling docker toolbox, oracle vm virtualbox, and git (all of which were included with the docker toolbox installer), I deleted the .docker and .virtualbox folders. I also tried installing xibo via docker toolbox on two other machines, with similar results.

I have a successful test install using docker for windows (on a newer machine with windows 10 pro) – that was relatively easy. I also have a test manual install – which was a pain, but not as frustrating as docker toolbox. Production consists of a couple of older machines (with windows 10 home) running a relatively simple set of videos and jpgs – if docker is to work, docker toolbox is currently the only option.

I appreciate your efforts - and if this is a one-off issue somehow related to my setup, there is no sense taking up any more of your time. I can proceed with a manual install for production. If there is the possibility that this is a broader issue, however, I am happy to try whatever additional thoughts you may have to get docker toolbox working.

Thanks again!

Thank you.

@Peter is running Docker Toolbox for test suite dev without issues as far as I’m aware, and I’ve lost count of the number of other Toolbox installs I’ve discussed on here in the past couple of weeks, so I’m pretty confident it’s isolated. If we do find it’s a more general thing then your offer would be greatly appreciated.