Docker: CMS invalid EmbeddedServerPort [SOLVED]

Dear all,

First of all all, I’d like to thank Alex and the rest of the community for this excellent and opensource Digital Signage platform.

I’ve been testing Docker Xibo v 1.7.8 and 1.7.9 for a couple of months now on my own text environment (old ubuntu server machine). I have created some test-layouts and used the windows Client to make sure everything worked. Thanks to the easy tutorial here it was very easy to setup, and everything worked like a charm.

Last week I received my new (but small) HP DL20 ProLiant server which I installed CENTOS 7. I installed the latest docker version (1.12.5) and got the latest version of Xibo (release candidate 1 of version 1.8).
Thanks to the powerful docker technology the CMS + XMR + DB was setup very quick and easy.

Next step I took is to connect the Xibo Windows Client (version 1.7.9) and authorise the display. Once the password is accepted I click on save and receive the following 3 errors

[DisplayTimeZone]
[XmrNetworkAddress]
[EmbeddedServerPort]

Here is the screenshot:

  • I checked the Timezone, as I’ve read on this forum the display timezone has to be the same as the CMS → They are!
  • I checked the network address by using the " docker exec -it xibo-cms-web bash" command and checked the config. Everything seems fine?

I have changed the XMR Public Address address from “localhost” to tcp://172.17.0.3:9505 and to the LAN IP address of the server. Nothing changes.

I finally decided to switch back to my old ubuntu server. Guess, what? I receive the same error. Even when I switched to an older docker image (1.8 beta and 1.7.9) I still receive these “invalid configuration option from CMS”.

What else could I check? Anyone got the same issue? Or some hints in what to check next?

Thank you in advanced.

Because of the 1-image-policy of this forum I still wish to share with you my other screenshots ive made
So I create a new post.

Here the network settings inside the docker (xibo web)

You’ll want to install 1.8.0-rc1 Windows client to use it against 1.8.0-rc1 CMS.

Check if XMR is correctly configured in the CMS as well, but installing 1.8.0-rc1 client would definitely be the first thing to do.

Thanks Peter,

I’ll look into it right away. I somehow managed to miss the latest version of the client :unamused:
Hope it works! I’ll let you know right away.

I’d like to add that we are really pleased you found this useful and easy! :thumbsup: :smile:

Hi,

Yes, very easy. I was not familiar with Docker but I had some issues with getting Xibo CMS to run using LAMP. Thanks to Docker there are no dependency issues anymore as everything comes within the docker image.

But to come back to my original issue of the topic;
Windows Client 1.8 rc1 indeed did the trick.

Thank you again.