Display not updating no matter what

Hello and thanks for your attention.
I have the problem that none of my displays are refreshing.
In my display tab it shows that all are authorised and registered.
Everything is green and it says that all are up to date.
I tried rebooting my displays, forcing to delete the cache and even setting up new displays.
None of them worked.
So you are my last hope. Do you have a suspicion why it doesn’t work?

Thanks in advance.
Best Regards,
Robert Kessler

I have to add that I run 2.0.3 with a manual installation and I tried to schedule layouts and even reassigned them.
Still nothing.
I think I overlooked something.

I have the same problem.
I do not have any filter, and I’m using default user …

Could you confirm as to what Players you are using, and how are they connected? If possible please provide us with some status screenshots.
What OS have you installed the CMS onto?

Have you checked the Logs in the CMS for any errors you are receiving from the Displays?

Please refer to the Troubleshooting page for further information regarding Error Logs and Player Status.

não consigo colocar aqui os printscreesns, coloquei numa pasta da Dropbox.

Estou a usar Windows 10.

Envio os logs

https://www.dropbox.com/s/cg2pngrrhlf2268/troubleshoot.zip?dl=0 https://www.dropbox.com/s/cg2pngrrhlf2268/troubleshoot.zip?dl=0

https://www.dropbox.com/sh/bahtcfoeqv6qb1h/AABWFbLBa7SPURMDTwV51Pgia?dl=0

Hi Jfelizardo,

I can see that you have attached some troubleshoot zip logs to be looked at but it’s not clear what you have recorded in those Logs, it looks like you clicked the Status dashboard which does not provide any further information about your issue.

I also took a look at your screenshots and one is of the status dashboard, the other looks like it is the Playlists option in your CMS. According to your screenshot, you have 3 Displays connected to your CMS but none of them are Authorised, which would explain why they are not receiving any updates:

I would first recommend that you go to the Displays option in your CMS, click the button at the end of each Display and choose Authorise. Select Yes to confirm you want to Authorise the Display. Once you have done that, restart the Display.

Can you let me know if this helps resolve your issue? If it does not, please provide a screenshot of the Status page form one of those Displays. Below are instructions on how to do that:

  • Go to the PC/device running your Xibo player.
  • Whilst the Player is runnig on screen, click the i key on your keyboard.
  • A small window will open, this is what I would like to see a screenshot of.

Many Thanks.

Já está tudo ok! Utilizei o Firefox, e consegui!

Obrigado

Thank you for confirming that everything is now working, really glad to hear that.

Welcome to the Xibo Community, I hope you do not run into any further issues with your Xibo setup.

Many Thanks.

Good to here that it worked out well for Jfelizardo.
But it won’t work for me.
I tried to authorise / de-authorise many times with restarting all of my displays. Didn’t work.
I looked at my logs and I figured out that I get following errors:


I can’t send any command to my displays because of this XMR thing.
Could this be a problem to think about?
I googled for his problem many times and it was very confusing with the file in my FTP-Server that I have to execute and the associated config file.
The troubleshoot file: File-Upload.net - Datei nicht gefunden

Best Regards,
Robert Kessler

Hi robert.kessler,

XMR is an optional feature that can be used with your CMS so that your Player and CMS can communicate without the need to wait for the Collection interval. If this is not configured it still should not stop your Displays from connecting and receiving up to date schedule information.

Can you confirm what Players you have connected to your CMS? Please also provide a screenshot of the status page from those Displays.

You can access the status page on a Windows player by clicking the i key on your keyboard while the Xibo Player is running.

For Android Players you need to click on the screen while the Player is running and choose Status from the Action Bar at the top of the screen.

Also can you confirm what the collection interval is for your Displays and if they are regularly contacting your CMS as expected.

Many Thanks.

Hello Dan,
I do have an android player and this is the status:



Here the status page of the displays:

The collection interval is one minute.

I hope I could provide helpful information.

Edit:
I think it’s working now however I didn’t do anything.
That’s awkward.
The XMR problem still exists.

Thank you for your screenshots and the further information about the Collect Interval.

It’s great news that the Player is now updating but I worry that without understanding this issue it could reoccur. 1.8 R102 is an older version of Xibo for Android, I strongly recommend upgrading that to 1.8 R108, which is the Latest revision of that Player.

Upgrading the Player simply involves downloading the APK, copying it onto a USB or other storage device and connected that to your device. You can then use a File Browser app to select the APK and it will do the rest for you. No need to uninstall the previous version.

Here is the download page where you can get the APK for 1.8 R108:

https://app.xibo.org.uk/download

This does not ensure a solution to whatever was happening before but it will help to count out any known bugs which were patched since R102. I would then recommend keeping an eye on this issue in case it happens again.

Regarding XMR, the errors state that it is not configured. below are links to the Prepare your Environment and XMR setup guides which explain how to install ZeroMQ and configure XMR:

https://xibo.org.uk/docs/setup/prepare-your-environment
https://xibo.org.uk/docs/setup/xmr-push-messaging

Many Thanks.

Ok thank you for the quick response.
I’m currently using a FireTV Stick so it will be difficult to execute the APK I guess.
But I think there is definitely a way to do that.
If there is something wrong I will contact you.

Best Regards,
Robert Kessler

Thank you for the update, I’ll wait to hear from you should you have an issue.

Many Thanks.