Dataset CSV Import: no german characters

I am testing dataset in V1.8

Import CSV works with some troubles in the date-format, but anyway, the bigger Problem is, that i do not see our ä ö ü characters, only “?” instead

In Settings - regional language is de-DE.

what can I do ? Please dont say “…use ae, oe ur ue”, that is not German


Is your CSV UTF-8 encoded?

Hi Alex,

I think, most of us use Excel for creating dataset data. Excel itself can NOT be used to create CSV-Files coded in UTF8. Also the Editor in Windows cannot save in the right Format.

There are two Problems:

  1. you cannot change or determine the separation character within Excel, maybe you can change it in your System / Region settings, but on my PC Excel does not recognize such a change.
    I use the chain-funktion in Excel to create the right format with “,” (comma" as the separator
    Looks like
    Montag,07.11.2016,Reisfleisch mit Salat,Pudding,AOMGHC
    Dienstag,08.11.2016,Tomatensuppe,Topfenknödel mit Apfelmus,GAC
    Mittwoch,09.11.2016,Alaska Seelachs auf Petersillienkartoffeln mit Salat,Obst,CAGMO
    Donnerstag,10.11.2016,Naturschnitzel mit Reis und Gemüse und Salat,Joghurt,AGCLOM
    Freitag,11.11.2016,Knödel auf Wildsoße mit Salat,Kuchen,ACGM

Note: I cannot use “,” (comma) within my text, because it is the separator

  1. After creating my data, I have to paste/copy it to Notepad++, mark all and change coding to UTF-8. Now I can save and Import in xibo.

I have 5 fields and about 20 records, that is no amount of data. When you have more you have to do some work every time you Import your data.

I would like to have in the CSV Import Dialog:

  • pre fill the column fields with the column number out of the dataset (someone who like to change something there should do so)
  • a small field to determine the separation character (perhaps save this for further usage), Separation char should be “;” (semicolon)
  • Chrismas Comes: automatic re-coding to UTF-8

best whishes to you and your team

CSV is comma separated variable. The comma is the standard separator. If you want to use commas in your content, then the individual elements need to be quoted - eg

"My, Field, 1","My Field 2"

Again that’s “standard” as far as CSV files go. Excel should do that automatically on export - I’m certain it does.

I’m really surprised that Excel is incapable of generating a compatible CSV file. UTF-8 is the standard for transferring those kinds of characters. We can’t know what they are if they aren’t UTF-8 encoded.

Lot of other ways to display menus. I have a website for a cantene with a page sliding menu items and price with a nice picture of the dish. Works great on narrow casting systems. Use a slide show plug-in in wordpress to achieve it. CSV is so dull. I dont think we will ever use it.

That’s your choice Rob.

Your Wordpress plugin won’t keep working if the connection between the Player and the webserver stops working, and there’s no reason you can’t use a dataset to make a menu with images, and transitions between the items in it. Datasets are cached locally so will continue to work whatever.

thank you for your posting.
your are right, there are a lot of methods to display menus. But we have xibo and xibo has datasets and we shall use them because:
there is only the man who cooks and he uses Excel to submit the menue plan to the School and the kindergarden and I am searching for a possibility to bring his data into xibo with a few clicks every month. Nobody is here to work with wordpress or SQL or anything else… (although we could do this)

CSV means CommaSeparatedValue but also CharacterSeparatedValue. May be in the anglo american room the comma is standard, in europe german room we use the semicolon. and also : TAB or blank are in use depending on the Software used.
When you install Windows with german params you get the “;” as the separator in your Region Settings. Even a change of this makes Excel NOT to use this. I also did not find any posibility to tell Excel to save with comma as the separator. By the way, in german the comma is the decimal separator in amounts, we write Euro 10.000,00 and you write $ 10.000.00. this is another reason not to use comma as a separator.

you are right, to use a comma within text we can use quoted fields. I found no possibility in Excel to generate this Format. May be by using macros or fill in quotes by hand…

As i wrote, MY only way to get a correct data Format (incl. UTF-8) for xibo ist the method I described above, hoping, somebody does this Job more simple than i…