Data Sets not retrieving data

CMS: 3.0.2
We’re working to pull in data from Solarwinds to display graphs and info. One manual change I had to do is import the certificate to curtl-ca-bundle.crt, as solarwinds uses a self-signed cert for the API calls.

url:https://user:pass@solarwinds-orion:17778/SolarWinds/InformationService/v3/Json/Query?query=SELECT%20NodeID,Caption,IPAddress,StatusIcon%20FROM%20Orion.Nodes

I created a new dataset, created the columns and ran the task to get data. It was very fiddly to get it to that point, with the data not populating when choosing a data root. At some point, the stars aligned, data flowed and the world was great.
Then I changed the URL to get more data, adding appropriate columns. Now I have no data imported, the Test Data URL doesn’t display anything. If I run curl from the server itself, I see data displayed. If I run wireshark and run the dataset task from the client, I see data in wireshark, so I know the call is being made and something is coming back.
I tried creating a new dataset, but experience the same results. This looks like it could really show some neat info, if I could only get it to work consistently. Ideas?

I put the logs to debug mode and ran the import task. It seems to find the data and start processing it, then abandons it with the error "Error syncing DataSet 11. E = "

Screenshot 2021-09-13 094744

The Xibo Community site uses cookies. What are cookies?