Custom theme error after upgrade to 1.81


I just did a test upgrade from 1.74 tot 1.81 (docker). In my 1.74 version I used a custom theme.

Now when I try to access the 1.81 version, it tells me “Fatal Error - sorry this shouldn’t happen. The theme “mymdash” does not exist” (Where mymdash is my custom theme.)

Is there a way I can go to the default theme in my docker install ? (I know I can’t use my old theme anymore because of the new templating system.)

Thank you in advance.


You can run the following command in the mysql on setting table

UPDATE `setting` SET `value` = 'default' WHERE `setting` = 'GLOBAL_THEME_NAME';

That will change the GLOBAL_THEME_NAME to the default theme.

Thank you for the tip.

As I’m not fully understanding docker yet, how do I connect to mysql within the docker container ?

I installed the mysql client, but when I try to connect with “mysql -h -P 3306 -u root -p” it tells me it can’t connect. I also tried “localhost”, but that didn’t work either.

Any advice would be greatly appreciated ! :slight_smile:

To access MySQL from inside the cms-web container:

Find the exact cms-web container name with:

docker ps -a

Use the container name in this command

docker exec -it <container_name> bash

Then to finally access mysql:

mysql -hmysql -uroot -p <your_password>

Once you’re there you can execute the sql query I mentioned in my previous post ie

UPDATE `setting` SET `value` = 'default' WHERE `setting` = 'GLOBAL_THEME_NAME';

That should be all you need.

1 Like

Thank you. However I still could not connect. I solved my problem by creating a new database export, changing the setting in that database and then started the import/upgrade. Now my install is updating like it should.

Thank you for the help though !