# CMS Version 3.3.2 to 4.3.1

**URL:** https://community.xibo.org.uk/t/cms-version-3-3-2-to-4-3-1/36779
**Category:** CMS Installation
**Created:** [December 3, 2025, 3:30pm UTC](https://community.xibo.org.uk/t/cms-version-3-3-2-to-4-3-1/36779 "2025-12-03T15:30:24Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![NSCJon](https://community.xibo.org.uk/letter_avatar_proxy/v4/letter/n/a183cd/32.png) [@NSCJon](https://community.xibo.org.uk/u/NSCJon)
#### Post date: [February 6, 2026, 9:19am UTC](https://community.xibo.org.uk/t/cms-version-3-3-2-to-4-3-1/36779/6 "2026-02-06T09:19:43Z")

</div>

I am having the exact same issue. Upgrading from 3.3.12 to any version of 4 (I have tried a few times, but always get the same error and have to roll it back). I tried yesterday to go to 4.4.0. I did as instructed in the [upgrade documents](https://account.xibosignage.com/docs/setup/upgrade-xibo-for-docker-install) and when I brought the container back up, instead of loading the CMS in the browser, I get this error:

`Proxy Error The proxy server received an invalid response from an upstream server.`  
`The proxy server could not handle the request Reason: Error reading from remote server`

I am using custom ports, so wonder if it’s something to do with this?

I know about having to [change the MYSQL password](https://community.xibo.org.uk/t/mysql-logs-please-use-caching-sha2-password-instead-after-upgrade-to-mysql-8-0-xibo-4/30689), but this feels like it is happening before that would come into effect. I don’t want to follow those instructions and then not be able to roll back to 3.3.12 if it doesn’t work.

I tried to find any information about this problem, but none of the posts I found seem to mention this exact problem. Using some of the commands from these posts I got this info.

Running `docker-compose ps` results in this:

```auto
        Name Command State Ports
----------------------------------------------------------------------------------------------------------------------------------
xibo_cms-db_1 docker-entrypoint.sh mysqld Restarting
xibo_cms-memcached_1 docker-entrypoint.sh memca ... Up 11211/tcp
xibo_cms-quickchart_1 node --max-http-header-siz ... Up 3400/tcp
xibo_cms-web_1 /entrypoint.sh Up 127.0.0.1:8080->80/tcp
xibo_cms-xmr_1 docker-php-entrypoint /ent ... Up 8080/tcp, 8081/tcp, 0.0.0.0:9505->9505/tcp,:::9505->9505/tcp

```

I noticed that is said MYSQLD was restarting, so I ran `docker logs -f xibo_cms-db_1` to check the logs, which showed this:

`2026-02-05 15:17:07+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 8.4.8-1.el9 started.`  
`2026-02-05 15:17:07+00:00 [Note] [Entrypoint]: Switching to dedicated user ‘mysql’`  
`2026-02-05 15:17:07+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 8.4.8-1.el9 started.`  
`‘/var/lib/mysql/mysql.sock’ → ‘/var/run/mysqld/mysqld.sock’`  
`2026-02-05T15:17:08.462474Z 0 [System] [MY-015015] [Server] MySQL Server - start.`  
`2026-02-05T15:17:08.762300Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.4.8) starting as process 1`  
`2026-02-05T15:17:08.770093Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.`  
`2026-02-05T15:17:08.792922Z 1 [ERROR] [MY-012209] [InnoDB] Multiple files found for the same tablespace ID:`  
`2026-02-05T15:17:08.792971Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 2 = [‘mysql/innodb_index_stats.ibd’, ‘mysql/plugin.ibd’]`  
`2026-02-05T15:17:08.792993Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 3 = [‘mysql/servers.ibd’, ‘mysql/slave_relay_log_info.ibd’]`  
`2026-02-05T15:17:08.793008Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 4 = [‘mysql/help_topic.ibd’, ‘mysql/slave_master_info.ibd’]`  
`2026-02-05T15:17:08.793023Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 5 = [‘mysql/help_category.ibd’, ‘mysql/slave_worker_info.ib d’]`  
`2026-02-05T15:17:08.793041Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 6 = [‘cms/phinxlog.ibd’, ‘mysql/help_relation.ibd’]`  
`2026-02-05T15:17:08.793056Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 7 = [‘cms/session.ibd’, ‘mysql/help_keyword.ibd’]`  
`2026-02-05T15:17:08.793068Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 9 = [‘cms/usertype.ibd’, ‘mysql/time_zone.ibd’]`  
`2026-02-05T15:17:08.793083Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 11 = [‘cms/useroption.ibd’, ‘mysql/time_zone_transition_typ e.ibd’]`  
`2026-02-05T15:17:08.793102Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 21 = [‘cms/lkmediadisplaygroup.ibd’, ‘sys/sys_config.ibd’]`  
`2026-02-05T15:17:08.793116Z 1 [ERROR] [MY-012202] [InnoDB] Tablespace ID: 89 = [‘cms/daypart.ibd’, ‘cms/stat_archive.ibd’]`  
`2026-02-05T15:17:08.793150Z 1 [ERROR] [MY-012930] [InnoDB] Plugin initialization aborted with error Failed, retry may succeed.`  
`2026-02-05T15:17:08.793177Z 1 [ERROR] [MY-010334] [Server] Failed to initialize DD Storage Engine`  
`2026-02-05T15:17:08.793312Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.`  
`2026-02-05T15:17:08.793332Z 0 [ERROR] [MY-010119] [Server] Aborting`  
`2026-02-05T15:17:08.794842Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.4.8) MySQL Community Serve r - GPL.`  
`2026-02-05T15:17:08.794861Z 0 [System] [MY-015016] [Server] MySQL Server - end.`

That is about as far as I know what to do. @dsenette is any of that similar to your issue? @CraftedInSteel Does any of that shed any light on to the problem?

---

_[View the full topic](https://community.xibo.org.uk/t/cms-version-3-3-2-to-4-3-1/36779)._
