Client saved and waiting on license, doesn't show up in Displays

I had to rebuild my server as the HD took a major dump. All of the other displays connected just fine and all I had to do was approve the license and off they went.

One display is having an issue though. I go to Player Options and enter the necessary information and it says it’s waiting on a license. However, it doesn’t show up in the list of DISPLAYS.

I thought perhaps there was a duplicate Display ID so I tried to change it. However, it now gives an error: ERROR ADDING DISPLAY. Is there an algorithm for the Display ID I have to follow?

Attached is the XML from the display in question.

Please advise how to troubleshoot this.

xibo-config.pdf (54.8 KB)

That’s interesting.

It might be just browser issue, have you tried different browser / clear cache?

If that’s not it, you could try to uninstall it completely along with xibo config in roaming folder.

Then install fresh 1.7.8 and try again.

I’ve tried 2 different browsers on two different computers.
I’ve uninstalled, deleted the config files and reinstalled.

Same result. Says waiting on license but doesn’t show up in DISPLAYS.

What can I try next?

RESOLVED

After searching through other topics, I realized I had a group named the same as the player name. I was able to add the display successfully, although I did have to change the DISPLAY ID for it to show up displays.

right, that makes sense, apologies that I didn’t think about it earlier.

Yeah, that will happen, especially on cloned systems.

Anyway, I’m glad you were able to solve this problem.