Client not updating - This layout had not been built yet

Dear all,

I’m getting the following error when updating media. The layout status says it has not been built. In the log I am getting

103238 4f1fe03 2017-05-24 12:04 WEB GET ERROR /layout/status/23 Cannot build Layout. Unexpected error: Cannot find media

Suddenly came up after updating some media. I have tried re-updating it and delete the media from the widget and adding it again but am still getting the above.

Its happening on 3 layouts


What CMS version are you using please?

If you open the layout in the layout designer does it correctly show the new media you’ve added?

Is it completely new media file added or did you replace old media existing on the layout with the new one?

I’m Using 1.8 running on a ubuntu VM.

The media I updated are videos, they don’t play in the layout designer anyway. It is replacing old media.


I’ve done a bit more testing and removed the video from the layout all together and it still comes up with the same error. I have also added all 3 videos I updated to a new layout with no errors at all. So it’s either another piece of media or a deeper issue with those layouts.

Could you export your layout (the faulty one) and send it to me via private message please, we will take a look at it here locally.

I think i might be getting somewhere. I’ve just realised all my backgrounds are missing. I’ve had to re upload them to the library and assign them to the layout again but it seems to have sorted it. Now I’m just getting the “There are items on this layout that can only be accessed by the display” message, which I usually get, I think it’s due to weblinks and what have you so that doesn’t matter. Just hanging on for a client to show the new videos…

Yep all sorted. Strange the backgrounds would get delete form the library somehow, I have used the trim library recently, that wouldn’t do it would it, unless there was a bug that they weren’t getting listed as being in use as they were in a background and not a widget?

That’s correct.

Library tidy definitely should not delete images if they are in use, either on the layout or set only as a background image.

That being said, there was this issue - Library: Tidy routine deletes background images · Issue #1089 · xibosignage/xibo · GitHub (should be fixed in 1.8.1), but there is still ongoing issue with tidy library reported here - 1.8.1 - Tidy Library Broken · Issue #1174 · xibosignage/xibo · GitHub

So I found a bug after I had already been fixed!

Thanks for your help and prompt reply!