Cannot add new column to Dataset (Ver. 1.7.4)

I’ve been running into walls today, it seems.

While logged in as Admin, with all admin permissions checked…
I’m trying to create a new Dataset. I can create a new column, and can add rows to that column. However, when I select “View Column”, I get the expected pop-up where I can set the “actions”. But when I click on the “Add Column” button, the system delays… then brings up a pop-up of the entire CMS screen. And I cannot, ultimately, add a new column to the dataset.

I have checked to make sure browser pop-ups are allowed. I have tried this on the following browsers, and OSs:
MAC 10.10.4

  • Safari
  • Firefox
    Windows 7
  • Explorer
    and had exactly the same results. In fact, it locks that screen from further selections. A Page refresh returns back to the main Dataset screen.

Data on my set up:
Xibo version 1.7.4, installed on a hosted LAMP, PHP setting check shows all ok.

I look forward to suggestions, Thank you.
~Eric

Hi Eric,

Sorry you’ve got this issue - do you by any chance have a special character in your Data Set name (it looks like you might?)

If so then this might be a bug

Dan,

Just to also note here. We have experienced database corruption issues in the past when using special characters as well. This happened when a user would upload media with apostrophes in them. The system will accept them but everything goes down hill from there.

I’ve been plagued with database corruption issues, and a wide variety of issues from the start.

  • I’m battling a mod_security issue in Apache (something the CMS is doing, when working on layouts, is triggering a security lock in Apache on my hosted server. The mod_security file notes (id:340017) “20 in the last 3600 seconds”; and the server bans my own IP address.
  • When working on layouts, then going to the “preview layout” screen to see what they look like, I have not once seen a complete preview, it takes a long time to load, and some fields don’t ever load. Instead they show “Internal Server Error”. If I refresh the preview, other different fields will not load, and those that error’d previously, will now display.
  • Finally, I have a licensed version of Android player that refuses to download the correct fonts. I have even resorted to uninstalling the client, then reinstalling it, and still the fonts will not download and display correctly. And I’m not talking about some exotic font - I’m using the basic, pre-installed ‘Comic Sans’ font that comes with the CKEditor package (default installation of Xibo). I know the layout is good, because it plays perfectly on a completely separate Windows client. Including the proper ‘Comic Sans’ font.

I admit to being a newbie. And I’m a careful reader, community ‘searcher’, and studier. But these faults are just not normal newbie mistakes. These are wild failure modes I cannot find in any search of our community or even Google.

I have since resolved the Dataset issue (beginning of this post) out of shear desperation, by completely wiping my server directory and deleting my SQL database, then doing a fresh CMS install. As for the other problems… I’m stumped. I have a slight suspicion that perhaps the communication between my controlling desktop and the CMS is slow… but I cannot explain why. I have a robust Verizon FiOS internet connect, speed should not be an issue. The PHP settings are all checked, and confirmed good, the CMS shows all “check marks”. As yet, I’m unable to explain the “preview unpredictability” problem.

As for the Licensed Android client font problem… I have a trouble ticket in with Spring Signage, but none of the suggestions has worked thus far. Still can’t explain why the other active (non-Android) clients display it with the correct font, but the Android client does not. (for reference, Android version 4.4.2,).

I thought I’d update my topic here…
I’ve made some progress. I tried to upload a new font, similar to the ‘Comic Sans’ font we wanted to use for this application, through the Media Library upload on the Xibo CMS. While the operation did work, and the font style successfully changed on the Windows client (which wasn’t giving us problems anyway), it still did not change the font style on the licensed Android client.

I did ultimately solve the problem, however. I compiled a custom ROM for the Android client and included a Google-based font similar to the choice we wanted, then rooted and re-flashed the Android CPU with the recompiled 4.4.2 version.
This resolved the problem.

As for the mod_security issue mentioned above; I have not been able to answer the question of ‘what’ was actually causing the problem, but I have learned through trial and error that it appears to occur (for me) when using a Safari browser (in this case Safari 8.0.7). When using Firefox (build 39), I have not yet tripped the mod_security trigger in Apache. It might be just a supposition on my part, but if the Safari browser has the potential to trip Apache security triggers by doing something unusual in the background - it’s just possible that it could also be the source of my odd file corruptions. I’ll have to experiment more with this hypothesis.

The delayed, and often incomplete “preview layout” screen issue, still continues; however the clients load and display all the layouts and media correctly.

This may sounds like an obvious thing to say but in the interests of others reading this ticket it should be noted that “standard” fonts will only display if the device has the font installed. If the font doesn’t exist then the default for that device will be used instead.

I’ve not come across an Android device that did not have Comic Sans installed - but it looks like yours does not. The unfortunate thing is that we do not have permission to distribute that with the package which means we have an unsolvable problem that effects a small number of devices (yours is the only report we have ever received).

We suggested uploading a custom font and are sorry to hear that didn’t work for you. Most custom font issues are because the font has restrictive permissions (i.e. it must be installed and cannot be referenced by a webpage), but as it worked on Windows that is unlikely to be the case. Please feel free to provide the font on your ticket with us and we would be happy to run some tests with it.

Regarding mod_security - we’d be interested to see what we are doing incorrectly in the designer. There is a lot going on with forms loading and previews refreshing.

20 of anything in an hour doesn’t sound like a large allowance? But I suppose that depends on “20 of what”.

I think we could have avoided this quite simply - but I don’t think we had a response to our question? Sorry if I missed it.

Are those fields all in their own region? If so then that is a LOT of regions you have there and we would be interested in understanding your reasoning for so many. If they are all separate regions then I would imagine your web server is saying that enough is enough and there are far too many concurrent requests.

Happy to look at an export of your Layout (with CSV representation of your DataSet if possible).

Dan,
These are keen observations. I completely understand the comment regarding being unable to control the Android software package. It is true, especially with these generic Android systems that can be purchased so inexpensively, that you have no idea who compiled, or what was compiled in the ROM.

Your observation about the number of regions is a keen one. There are 45 regions in that one unique layout. I chose this format to prevent my client from having to realign the text each time she makes a change to the “beer name”. In a single region format this proved to be a hassle for her to keep the prices aligned. In this design, she simply updates the data in the dataset, but does not have to be concerned with it moving the alignment of the associated price, which appears in a different region. From a usage stand point, it worked perfectly.

I wasn’t aware that each region was it’s own concurrent request. Is there are maximum number of regions the system allows, or is there a break-over point where x number of regions begins to present a system performance penalty? This would be important to know.

Thank you for your generous offer on the Layout, however your information above may help me to experiment and possible reduce the complexity of the Layout. I will continue to work on it.

You’ve hit the nail on the head - its the blessing and the curse of these devices

Blimey :smile: that is a lot of regions. We haven’t imposed a strict limit on the number of regions you can have but would say that most “normal” layouts wouldn’t need more than 3 or 4. Regions are intended to split up your screen into “zones” that can have their own time line of media assigned - for example a video region and a ticker region are common scenarios.

You can consider each region to be its own mini “program”, both in the CMS and in the 2 players. This means that on the CMS each region consumes a web server request to render and in the players it consumes some RAM and CPU time. We test each release with a layout that contains 16 regions.

If you’re needing 45 regions then I think there might be a misunderstanding over what you can achieve without introducing another region.

If you have a dataset with a “beer” and a “price” that you want displayed in a tabular fashion like your screen shot, I think you want to be considering a DataSetView media type on your DataSet. Have you tried that and run into problems?

Dan, No I haven’t tried it, but I will experiment with it. Initially when I worked with DataSetView I found it to be limiting. However, I need to reconsider my options, this is a different usage that may work.

Thanks for your comments!