*Bug* edit user form and delete user

The save button’s spinner replicated itself everytime I pressed it
and it didn’t save the password, which was $"DIX%U:!8cV#^TzO0Hv.

After a little bit bugsquashing this error also occured on the delete user section.

We somewhat modified your code to force https through .htaccess

RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://easyxibo.nl/$1 [R=301,L]

RewriteCond %{SERVER_PORT} 443
RewriteCond %{HTTP_HOST} !^easyxibo.nl [NC]
RewriteRule ^(.*)$ https://easyxibo.nl/$1 [R=301,L]

I added this on top of your code.

I use those rules in a lot of sites and it never produced an error,
it even works in OSCommerce sites

Could it be you rather use the www. in front of the domainname?

Thanks in advance,
Marnix Mulder

Eventhough I changed it back, it still occurs.
It also happens in my settings…

Thanks in advance,
Marnix Mulder

There’s a force HTTPS mode in the settings which might be a better route than modifying the .htaccess file.

I presume this is a custom install. What’s the environment? How are you referencing the Xibo codebase? Virtual Host with document root set to the “web” folder? Or an Alias?

What does the login page URL look like? ie is it https://myserver.com/xibo or just https://myserver.com?

Our host uses the public_html folder,
they symlinked public_html to web.

Xibo and all of its files are in the web folder,
except for the cms, which is one folder up, so it’s not publicly readable.

My problem is that the force https doesn’t work, since xibo doesn’t seem to update/delete anything.

URL is https://easyxibo.nl

You don’t have it enabled in the settings as far as I can see without a login.

If you go to the CMS settings page, tick “Force SSL” and it will redirect http access to https without you making modification to the .htaccess file.

I’m not sure what the issue with the user edit can be as I can’t replicate it here. You’d need to run through the report fault wizard and see if any errors are logged.

I can’t force https through csm, same error occurs.
I ran the troubleshoot wizard, but it didn’t really return anything.

If it helps out, I created an account for you.

However it might not be save to share them here.

You can PM me the login details.

I agree that changing the force http option won’t fix your original issue, but that’s how to enable HTTPS in the CMS rather than editing the .htaccess file.

Not really familiar with your forums, i tried through your profile, but didn’t see a pm button or something like that.

Click on my photo, then press “Message”

Unfortunaly I don’t see that option, could it be because I’m a fairly new user to the forums?

Probably. You need to read other posts and/or contribute for a while to get full privileges. I’ll message you.