Apache assistance?

Hi there.

I’ve set up a xibo cms server on WAMP 3.0.6 with Apache 2.4.23 and it sorta works with a local screen saver player. Back to that later. The server and player are on a Win7 installation in another room. I’d like to access the CMS interface without having to use remote desktop (so I don’t disturb the player in action). PRoblem is, I can’t get past the dreded Forbidden 403 error when I try to connect from my desk computer. I’ve read up and down about virtual host setup and can’t seem to crack the nut.

My vhost file looks like:

Virtual Hosts

#original entry, untouched
<VirtualHost *:80>
ServerName localhost
DocumentRoot c:/wamp64/www
<Directory “c:/wamp64/www/”>
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local

my attempt to make this darn thing accessible

<VirtualHost *:80>
ServerName xibo.local
DirectoryIndex index.php
DocumentRoot c:/wamp64/www/Xibo
<Directory “c:/wamp64/www/Xibo”>
Options Indexes Includes FollowSymLinks MultiViews
AllowOverride all
Require all granted

In my logs I see the first line when connecting from the local browser on the ‘server’ and then the following lines when connecting from my desk… [I had to take a **t** out of http so it would not format those as links, preventing me from posting].

[Mon Feb 27 12:40:08.910945 2017] [authz_core:debug] [pid 3992:tid 872] mod_authz_core.c(806): [client ::1:65095] AH01626: authorization result of : granted, referer: http://localhost/xibo/

[Mon Feb 27 12:40:18.832608 2017] [authz_core:debug] [pid 3992:tid 872] mod_authz_core.c(806): [client 10.3.16.124:64639] AH01626: authorization result of Require local : denied
[Mon Feb 27 12:40:18.832608 2017] [authz_core:debug] [pid 3992:tid 872] mod_authz_core.c(806): [client 10.3.16.124:64639] AH01626: authorization result of : denied
[Mon Feb 27 12:40:18.832608 2017] [authz_core:error] [pid 3992:tid 872] [client 10.3.16.124:64639] AH01630: client denied by server configuration: C:/wamp64/www/Xibo
[Mon Feb 27 12:40:18.941809 2017] [authz_core:debug] [pid 3992:tid 872] mod_authz_core.c(806): [client 10.3.16.124:64639] AH01626: authorization result of Require local : denied, referer: htp://10.3.16.250/xibo
[Mon Feb 27 12:40:18.941809 2017] [authz_core:debug] [pid 3992:tid 872] mod_authz_core.c(806): [client 10.3.16.124:64639] AH01626: authorization result of : denied, referer: htp://10.3.16.250/xibo
[Mon Feb 27 12:40:18.941809 2017] [authz_core:error] [pid 3992:tid 872] [client 10.3.16.124:64639] AH01630: client denied by server configuration: C:/wamp64/www/favicon.ico, referer: htp://10.3.16.250/xibo

Any thoughts on why I can’t seem to get authorization to connect remotely?

Thanks,
Mark

You will need to connect via IP, which should be the IP of your PC running the CMS, the windows firewall might block connections to it, you can also check web server settings and make sure it allows outside connections, so something like https://john-dugan.com/access-wamp-from-lan-computers/ (not our webpage/guide of course but should give you an idea).

There is also this http://stackoverflow.com/questions/22805093/how-to-access-my-wamp-server-on-another-local-computer

Hope that helps.

Thanks, Peter.

I was using IP address to call from a computer on the same subnet like so “http://10.3.16.250/vhostname” where I replace vhostname with xibo or phpadmin or whatever dev project I want to reach. Apparently, I don’t have the apache chops pull this off :slight_smile: I found that I could get http://10.3.16.250/ to reach the first server in the vhost file list, so I just rearranged things so xibo login would be first. Works for me!

Now I can edit layouts from my desk without disturbing my combo screensaver player & server.