Android player unable to download files - MD5 errors

To be completed by the original poster:

CMS Version

Version 3.3.1

Installation Method

Custom install

Operating System

Ubuntu 22.04

Issue

Having upgraded our CMS from 1.8 to 3.3 the Android clients are no longer able to download any files from the CMS and I am seeing MD5 errors on the status page of the client.

I have tried running a Troubleshoot from the CMS but the zip file that is downloaded is empty!

Here is a link to a video of the status messages from the Android client whilst performing a Purge through the CMS to trigger a download of all files… https://photos.app.goo.gl/YrpNyz7qydycf6Vf7

Obviously with no files downloading to the client, our layouts are not working!

Any help, gratefully received!
Jon

Hi Jon_Wiits, thank you for your message.

Can you confirm if you upgraded directly from 1.8 to version 3.3, or did you make sure to upgrade from 1.8. to version 2.3 and then to 3.3?

The MD5 errors suggest that the files being downloaded from your CMS do not match the MD5 checksum that should have. My first recommendation would be to go to the Displays menu in your CMS , click the button at the end of the entry for this display and choose Edit. When the Edit Display window opens click save to clear the display cache. This should generate new requiredFiles and schedule files for the display, does this help resolve the issue?

Many Thanks.

Hi Dan,

If the docs recommended going via version 2.3 first then that’s what I would have done… I hope :wink:

I have been in multiple times trying to edit the display and that doesn’t appear to be fixing my issue.

Is it worth deleting the device and re-adding it?

Jon

Thank you for confirming that you have tried editing the display to clear the cache but it is still not working.

You could try deleting the entry and reconnecting the display, do you have other displays connecting to your CMS that do not have this issue?

Many Thanks.

Hi Dan,

I am going to double check our other display either today or tomorrow. If that one is also showing the same issues, I am tempted to just restart the whole installation from scratch and start with a clean install of 3.3…

I will let you know what I find.
Jon

Thank you Jon_Witts, I’ll wait to hear from you.

Many Thanks.

Hi Dan,

I decided to rebuild the server using the Docker images instead. So far so good and the issues with the client MD5 errors have gone away!

Jon

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.