Android EMUI 9.x.x can't connect to Xibo server


#1

Hi there,

We have an on-prem Xibo server in docker and are testing different Android devices.
We have problems to access Xibo server with devices that runs on Android EMUI 9.0.1, we can access the server in browser but in Xibo app it says Unable to connect to that CMS adress.

Somone out there who have a clue?

Best regards
Daniel Schwartz


#2

Are you using https? If so, check your certificate chain is valid. It may be that a browser is able to patch in missing intermediate certificates where the Player can’t.


#3

Hi Alex, no we are not using https, read something about that and docker that we are using.


#4

It may be something in that particular firmware then that causes an issue. I’ve got a generic Android 9 device here and that connects to a server as expected with the latest v2 release.

I presume an Android device running a lower version of Android connects to your CMS OK? Can you try connecting one of those to a Cloud CMS just to rule out something with the local install please.


#5

Hi,
Now we have set up a cloud cms, works fine with Lenovo 8.1.0 but with Huawei (EMUI) 9.0.1 we get an error message when requesting a license so https solved one issue but not all the way…
“We did not find your license pool, email adress in our system or no license were available …”


#6

Check that you have a free version 2 license in your pool. If you only have 1.8 licences, then they won’t be valid to license a version 2 Player.

If you email our service desk with your licence pool email address we can look at that for you - support@xibosignage.com


#7

I’m pretty shure there are only v2 licenses but I will send an email.


#8

Both of our licenses are v2 and I tried with another Lenovo tablet and it worked like a charm.


#9

Perhaps the date and time, or timezone are incorrect on your Android 9 device then. That’s the most common reason a device will fail to license correctly.

I see you’ve emailed support, so they will assist you.