Android 1.8 WEB Region SLOWWW! [SOLVED]


#1

Recently stood up a new Docker based version of Xibo 1.8.3 .
Once it was configured and online, I imported one of my layouts that is kind of CSS heavy
I noticed the CSS FX were playing very slow on my Android based 1.7 test player.
So I updated the test player app to 1.8 but, it had the same issue.

Created a new layout from scratch.
Added a webpage region pointing to the same URL.
Made new layout the default for the Android based test player.
Same result, slow CSS/Web performace taxing the whole player.

Is there something different about how layout handling web page regions that is adding more overhead?
Or is it something else?

It doesn’t seem player related since is see the same slowness on the 1.7 & 1.8 player APK.
The server version seems to be delineating factor.

Here are some example video links of the issue.

Xibo 1.7.7 server with 6 Region layers in the Layout

Xibo 1.8.3 server with only one Region in the Layout


#2

What setting have you got for “Hardware Accelerate Web Content” in your Android Display Settings profile?

If it’s set to Off when transparent, ensure you don’t have the transparent option turned on for that embedded/web widget.


#3

Your Rock!
That was the problem exactly!

  1. Display Settings
  2. Android - >Edit
  3. Advanced Tab
  4. Hardware Accelerate Web Content -> ON
  5. Save

#4

Setting it to “On” may not be what you want.

On means that it will always be enabled. That may make it impossible for you to show web content with a transparent background on some hardware.

If that happens, set it back to its default (Off when transparent), and ensure that the webpage or embedded widget is set not to be transparent instead.


#5

I only run Android players for this reason.
Not to mention they’re a third the price of a small WinPC.


#6

What I wrote does apply to Android Players. Windows Players have completely different settings. I’m just flagging with you that On is not the default setting for good reason, and you would be better turning transparency off on that widget instead. It is your choice however