1.8rc3 Does not change content on layout API/Postman

Hello everyone!
I installed 1.8rc and added a layout (test1) with a text. Now i set the default layout as default layout for this Dispaly and assigned the default layout and test1 to this display.
Now i changed the content of the layout with Postman so just another text nothing big. (And yes in the layout preview it is changed immediately) But it does not change the layouts’s content on the player EDIT: It takes 13 minutes :confused:
Why does it takes so long? I installed it with docker-compose do i have to do a command with xmr or something? And yes i set the Pickup interval to 1 minute.
What am i doing wrong? :sob:

Other question: Is this right in general discussion or development?

Okay i dont know ! Now it takes only 15 seconds… This can be closed.

It should probably be in dev category but that’s not a big problem :slight_smile:

Tell me do you have XMR configured?
Since you installed in via docker then it is pretty much already configured.

All you need to do is set the XMR public address in the CMS settings -> Displays tab
XMR will be listening for players on port 9505
so in public address you will want to put something like:
or tcp://hostname:9505

replacing the ip.address / hostname with correct values for your installation of course.

and what are the durations on your layout and do you have ‘expire modified layouts’ enabled in display profile?
As those settings can delay any changes you made from appearing on the player.

The public address for XMR is the ip adress of my xibo?
For ‘expire modified layouts’ i will look tomorrow.

Another question: http://xibo.org.uk/manual-tempel/en/xmr.html
This site said that i can cahnge layout instantly. But how? How can i send these ‘XMR’ commands?

Thank you ! :slight_smile:

Yes and with the XMR correctly configured and of course with 1.8 client as well, if you make changes to the schedule they should be executed pretty much instantly (+ time to download the content if it wasn’t already cached on the device) and there is API call changeLayout as well.

1 Like

Yes i activated ‘expire modifired layouts’.

Now i changed in Settings -> Display -> XMR public address & Display Settings -> Windows -> XMR public address to “tcp://localhost:9505” is this right? Why has to go “tcp” before it and not https?
Is that all for XMR? I think yes.

Thank you for your help :slight_smile: