1.87 on Docker Toolbox


I upgraded from 1.84 to 1.87 about a month ago, all seemed to go fine and I thought no more of it.

Then one day the back-end has no data after a server reboot, seems during the upgrade the shared folder was completely removed and there’s no trace of it on the system, not such a big deal as I had a backup from when I did the upgrade. Removed all traces of xibo and docker, reinstalled them but the shared folder will not be created… Tried a completely fresh install server to install and xibo still will not create the shared folder. I tried the fix that is in the install guide, nope.

Seems that my issue is compatibility between 1.87 + Docker toolbox + server 2008r2

Does anyone have any advice? I don’t want to have to go back versions…

Is it 32 or 64 bit system? Docker only works on 64 bit systems.

Have you installed it in /Users folder?
If not that could cause permission issues.

when you run the up command, does it show any errors?
what if you run docker-compose logs?

https://xibo.org.uk/manual/en/install_docker_winother_64bit.html and linked there https://docs.docker.com/toolbox/toolbox_install_windows/

Yeah x64, as mentioned this was a server that had been running 1.84 for some time, with version 1.84 the shared folder was there as I can see it on the backups.

Always installed to users\xibo perms all ok.

1.87 was working great for a month with multiple layout updates then one day boom - gone without a trace, looks like it was writing all the data to the docker vmdk but I can’t for the life of me get in to that file.

Tried to set 187 up on the separate virgin server but still no shared folder creation.

Just tried installing docker toolbox on to a brand new install of Win 10, followed the instructions to the letter and it does not create the shared folder… This is driving me mad. Anyone have any suggestions?

Could you run
docker-compose down

docker-compose up (without -d assuming you’re using default ports, if not use the up command for those)

It should show you logs of what it is doing and probably also where the problem is

So I spent far to long on this now, the logs would show no issues during compose, it’s like it didn’t try to create the folders.
My theory is there is an issue between the new version 18 of docker toolbox and xibo, I have recreated the issue on seperate PC’s and Windows versions.

In the end I spun up a Debian box and installed the docker, boom working a charm with all the correct folders, survives reboot etc.

I’m happy to take a look over TeamViewer if you would like.

Please PM me TeamViewer connection details and I’ll look

I’ve had to leave the office now, I’ll PM you tomorrow… Thanks!