1.8.0alpha3 unable to edit a RSS region

After having updgraded the CMS on version 1.8.0alpha3, an RSS feed inside a region of a previously created layout can’t be edited.

Error message appearing is :
Application Message
Unexpected Error, please contact support.

Here is enclosed the log file (txt renamed as odf to be uploaded) : logrss_txt.pdf (251.0 KB)

Thanks

It looks to me like the widget is corrupted - you will have to delete it and add it again i’m afraid.

Do you think you might have deleted the underlying DataSet that the widget uses?

[2016-05-03 09:31:25] WEB.DEBUG: An exception has been thrown during the rendering of a template ("DataSet not selected") in "ticker-form-edit.twig" at line 24.#0 /home/m21dev/www/daxpro/cache/30/3040e9519e906096c74ac4f415abe4e0815a9311789a95c6257ebde34bbe1447.php(53): Twig_Template->displayBlock('extra', Array, Array) #1 /home/m21dev/www/daxpro/vendor/twig/twig/lib/Twig/Template.php(381): __TwigTemplate_98a5f71c4f03e6209ee30c9388026ed865e8fc07eebd5e5353a093d9abd79d2d->doDisplay(Array, Array) #2 /home/m21dev/www/daxpro/vendor/twig/twig/lib/Twig/Template.php(355): Twig_Template->displayWithErrorHandling(Array, Array) #3 /home/m21dev/www/daxpro/cache/d6/d69fcf9e2bfeb2e7feb925fcc225f6dca9ee59683a1bebdd7c9c3b8fff8cf7fc.php(32): Twig_Template->display(Array, Array) #4 /home/m21dev/www/daxpro/vendor/twig/twig/lib/Twig/Template.php(381): __TwigTemplate_fc015ab5840a0313f5ce125aeadeff99e2e39c23a23d2fdf09f4ec24e6257f7b->doDisplay(Array, Array) #5 /home/m21dev/www/daxpro/vendor/twig/twig/lib/Twig/Template.php(355): Twig_Template->displayWithErrorHandling(Array, Array) #6 /home/m21dev/www/daxpro/vendor/twig/twig/lib/Twig/Template.php(366): Twig_Template->display(Array) #7 /home/m21dev/www/daxpro/vendor/slim/views/Twig.php(91): Twig_Template->render(Array) #8 /home/m21dev/www/daxpro/lib/Controller/Base.php(409): Slim\Views\Twig->render('ticker-form-edi...', Array) #9 /home/m21dev/www/daxpro/lib/Controller/Base.php(324): Xibo\Controller\Base->renderTwigAjaxReturn(Array, Object(RKA\Slim), Object(Xibo\Helper\ApplicationState)) #10 /home/m21dev/www/daxpro/lib/Middleware/State.php(99): Xibo\Controller\Base->render() #11 [internal function]: Xibo\Middleware\State->Xibo\Middleware\{closure}() #12 /home/m21dev/www/daxpro/vendor/slim/slim/Slim/Slim.php(1210): call_user_func_array(Object(Closure), Array) #13 /home/m21dev/www/daxpro/vendor/slim/slim/Slim/Slim.php(1358): Slim\Slim->applyHook('slim.after.disp...') #14 /home/m21dev/www/daxpro/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim->call() #15 /home/m21dev/www/daxpro/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash->call() #16 /home/m21dev/www/daxpro/lib/Middleware/Actions.php(133): Slim\Middleware\MethodOverride->call() #17 /home/m21dev/www/daxpro/lib/Middleware/Theme.php(73): Xibo\Middleware\Actions->call() #18 /home/m21dev/www/daxpro/lib/Middleware/WebAuthentication.php(133): Xibo\Middleware\Theme->call() #19 /home/m21dev/www/daxpro/lib/Middleware/CsrfGuard.php(62): Xibo\Middleware\WebAuthentication->call() #20 /home/m21dev/www/daxpro/lib/Middleware/State.php(103): Xibo\Middleware\CsrfGuard->call() #21 /home/m21dev/www/daxpro/lib/Middleware/Storage.php(46): Xibo\Middleware\State->call() #22 /home/m21dev/www/daxpro/lib/Middleware/Xmr.php(38): Xibo\Middleware\Storage->call() #23 /home/m21dev/www/daxpro/vendor/slim/slim/Slim/Slim.php(1302): Xibo\Middleware\Xmr->call() #24 /home/m21dev/www/daxpro/web/index.php(120): Slim\Slim->run() #25 {main} [] {"uid":"ff9230d","method":"GET","route":"/playlist/widget/form/edit/:id","userId":1}
[2016-05-03 09:31:25] WEB.ERROR: An exception has been thrown during the rendering of a template ("DataSet not selected") in "ticker-form-edit.twig" at line 24. Exception Type: Twig_Error_Runtime [] {"uid":"ff9230d","method":"GET","route":"/playlist/widget/form/edit/:id","userId":1}

I have no reminder of having deleted the underlying dataset, as this ticker was a RSS feed and not linked to a DataSet. May be during upgrade some library files were lost ?

I have deleted the widget and recreated it, adding a ticker of type feed, and an error occurred :
Application Message
Unexpected Error, please contact support.
Here is the log file : logrss2_txt.pdf (99.7 KB)

OK, that is interesting! Turns out it was a bug:

There is a commit there that should solve it for you.

Ok, I’ll update the php files on my installation

1 Like